Home        Store        Learn        Blog

Is Companion compatible with Raspberry Pi 4?

I know this is an old thread but I happen to have a Pi4 atm and checking the ArduSub docs the most recent version is 3.5.4. Any info when 3.6 will be relesed (stable)? I consider myself a novice, is it better to get the Pi3? I am planning to complete my ROV2 around april next year, any chance there is a version 3.6 out by then?

Hello Josef,

I believe you mistook the Rasbperry Pi 4 with the Pixhawk 4. The Raspberry Pi runs our companion software, while the Pixhawk is the flight controller itself and takes care of stabilization and moving the ROV.

We will work in supporting the new PIs in the close future (currently both 3B+ and 4 are unsupported) so you may want to wait for that. For the Pixhawk, I would stick with the regular one for now.

Thanks Willian,

Yes I believe that I confused everyone including myself, to many Pi’s…:slight_smile:

That part is clear now, but when you say “currently both 3B+ and 4 are unsupported” I assume that the 3B+ is different from the 3B that you are selling and the one that works?

Yes, they do have some differences, take a look here.

Thank you…:slight_smile:

A post was merged into an existing topic: Is Ardusub compatible with pixhawk 4