Home        Store        Learn        Blog

Camera Tilt Issue

Did a full update of all the software to the latest beta version. Seem to have everything working but camera tilt. Can’t seem to get any movement.

Have it setup on Channel 8 and RC10 input.

It had all worked fine before.

Any ideas?

Hello, camera tilt recently changed in ArduSub 3.5.2, released just last week. I am still preparing an update for QGC to go with it before going public with it.

You need to set the MNT_JYSTCK_SPEED parameter to 100 or so. Please let me know what you have this set to currently, and if changing it fixes camera behavior.

ALSO, the input channel should be channel 8, not channel 10.

Ok set it to 100, it was 0. Input and output are now set each to 8.
It now moves but goes from full up to full down. Doesn’t seem to be any control over position when pressing the buttons, just goes to the extremes.

Please unplug-replug the battery, close, reopen QGC, and try again. After doing that, what does the Firmware version say in Summary->Frame?

I set it back to 0 and now it works properly, moving with button press.

Firmware is 3.5.1

Ok, if you selected the ‘beta’ version of ArduSub, that was still sitting at 3.5.1. I’ve just updated the beta to match the stable at 3.5.2. I’ll be making a post this week about the updates.

1 Like

The solution to the original issue was that your input channel was not configured as channel 8.

Great thanks, that seems it may have been just the channel issue. Seems fine now, thanks.

Now to sort out the video lag issues with QGC. I posted another thread on it. What would be the best version to use with the 3.5.1 firmware to remove the lag issue?

Which kind of camera are you using, and what is your OS on the surface computer?

It is the Standard Pi HD camera. Windows 10 OS but just with integrated graphics.

I ran another build of QGC that someone posted with video capture removed and it fixed the lag but it was giving me warnings on parameters JS_LIGHTS…

Using the latest QCG with capture I have no param warnings but the lag.

I also need to run QGC in safe mode or I don’t get any video feed.

  • Please go to 192.168.2.2:2770/camera in a browser.
  • Remove the line that says --intra 1
  • Click ‘Restart camera’, and let me know if you see any difference in the video performance.

Was still laggy and more pixilated with that change.

Running the other build now and seems fine, no parameter issues now. So maybe something was out of sync. Just wish the capture version wasn’t lagging so could use it but maybe just this laptop is the issue?

The QGC version needs to be matched to the firmware version on the autopilot. This is why you get warnings about parameters missing sometimes, it means that the firmware on the autopilot has some changes that QGC is not aware of.

Using the latest software on both the laptop and the ROV will resolve this issue.

The video lag issue is a problem on a small fraction of computers running windows, but there are steps that can be taken to resolve the issue. I will post some troubleshooting tips to your topic directly regarding the lag.

Hi Jacob,
Camera tilt and pan servo not responding, I am using latest ardusub and QGC v3.2.4 bluerobotics Rev6.

I have connected the pan and tilt servos to channel 7 and 8 . Also tried with giving servo 5V from raspberry pi GPIO. Using F710 logitech controller. controller is able to arm and disarm but no servo motions please help. Buuton 9 mount_tilt_down and 10 mount_tilt up

Check the setting at the bottom:
image

If it doesn’t work, send a parameter file please.