Home        Store        Learn        Blog

Latest QGC + ArduSub working combination?

I’ve recently built the latest daily QGC, and am getting the “missing parameters” message (a la here and here), but have tried with the latest stable (4.0.2), beta (4.0.1) and development (4.2.0) versions of ardusub, as well as 3.5.4, and all of them seem to have the same issue. Is QGC ahead of ardusub now instead of the other way around?

Would be great to have a QGC commit to revert to, or know which ardusub version should work successfully.

For reference, the missing parameters are 1:FLTMODE1 through to 1:FLTMODE6 and 1:r.RC6_OPTION through to 1:r.RC16_OPTION.

Also camera tilting seems to not work now with this new QGC (output: Channel 8, input RC8), which would seem to be consistent with it not being able to recognise 1:r.RC8_OPTION . I hadn’t calibrated the joystick before, and camera tilting worked fine after doing so. From that it seems that 1:r.RC8_OPTION isn’t related to RC8 which the camera mount uses, since using RC8 for camera mount works fine…

My old QGC version (4.0.10) seems to work fine, but doesn’t have my customisations (I added an extra sensor spot), and I’m feeling like there should be a more recent functioning version, since that’s still on quite an old version of the UI.

Hi @EliotInsight,

Yes, QGC and ardusub master are slightly out of sync.
The missing parameters are probably due to ArduSub being the only ArduPilot Vehicle with no RC support, with means the parameters for changing flight mode via RC values do not exist.

Hi @williangalvani,

Thanks for the response. Given QGC is ahead of ArduSub, do you happen to know a recent QGC version/commit number which isn’t missing parameters? The popup is annoying every time we want to modify the settings, but I’m not sure if the parameters were introduced before or at the same time as the new UI, or if there’s an available option somewhere in between that has the improved UI but doesn’t complain about missing parameters.