Camera TIlt and Thrusters controls lost after software/firmware updates

Hi. I had a functioning BlueRov2 which needed long due updates to software and firmware. After updating QGC to version 4.2.3 and Ardusub to 4.1.0 I am now experiencing 2 issues (they might be related though):

  1. The camera tilt is not working at all
  2. There is no response from the thrusters when I try to control the movements with the joystick (Logitech Extreme 3D Pro)

NOTES:

  • The joystick is calibrated correctly and all the buttons are assigned correctly (they were reset to default after the updates)
  • The thrusters themselves are actually working properly as all tested through the “motors setup” section in QGC, they all respond correctly so it’s not an issue with cables, connections or mechanical.
  • When I push the related buttons on the joystick I actually receive correct feedback about Camera Tilt % on the console, as well as Asc Rate %. So the software seems to respond to the controls from the joystick, but the ROV does not.
  • At some point, following another post, I also loaded default frame configuration parameters. Don’t know if this is relevant, but in that moment it seemed to have messed things up even further.

I have tried everything that came to mind and went through similar posts in the forum but no success.

Please help, I’m getting desperate and urgently need this for work…

Thanks

Hi @Scubalibre, welcome to the forum :slight_smile:

I believe there have been some issues with that recently - it should hopefully be fixed by resetting the parameters via the Parameters page, and then rebooting the vehicle. From there you may need to re-configure the camera mount, lights, and leak sensor.

That sounds like the camera tilt servo is not connected to the pin that’s configured for it. I’d recommend you double-check the correct pin is selected in the Camera Mount Setup Page, and that the servo is fully plugged in to the pin you’ve configured :slight_smile:

Hi Eliot,

Thanks for the speedy answer. It all worked out!

Cheers

1 Like