My motor is not spninng

In the motor setup. It is completed with auto mode. And I can control them in manual mode in the QGcontrol.

My xbox controller is calibrated(QG ground control get its signals)
But the drone is not move when I arm the drone and the motors are not spinning. Can someone help me debug this issue?

I don’t know where it could go wrong.

Thanks in advance.

I had some trouble with controlling our Bluerov(pixhawk version).
It connected fine to QGC and Joystick was enabled. “Arming” the vehicle worked, tilting the camera and turning off/on the lights worked fine too. Also, the commands for putting in “depth hold” or “stabilize” mode works either .But the thrusters didn’t respond at all.

I tried all of this :

  • In QGC settings > Motors : I tested all the motors individually, manually. They all work fine.
  • I tried rebooting the ROV (replugging the battery), but that didn’t do anything.

More specs :

  • using a xbox controller
  • QGC 4.2.3
  • Ardu Sub : 4.1.0
  • Companion : 0.0.31


I have the same problem as you.

Did you find any solution that you could share?


I end up recalibration everything with the drone and it works out eventually.

One thing we did is that we tried to install QGC on ubuntu and tried it there. The drone is working but we end up losing the camera feed in the QGC

1 Like


I did what you said and now it works.

Thank you very much!

1 Like