Home        Store        Docs        Blog

Unable to control motor #1


(Konstantin) #1

Hi,
Finally abused now, help me somebody please=)
After the assembling of my Bluerov2 has finished, I’ve started testing the ROV and setting the controls.
Can not clearly say, but looks like after that the motor #1 has stopped working. Tried to swap motors - the motor itself is fine. In an automatic control mode in QgroundControl this motor #1 starts to spin and does not stops, while the other motors are still.
Already checked all the electronic connectors, updated software and tried to reset Pixhawk to defaults - no results


(Jacob) #2

Can you please clarify the problem and how you are testing it? It sounds like in one case the motors work except for Motor #1, and in another case only motor #1 works.


(Konstantin) #3

Well, thats exactly how it works - motor #1 works in the autopilot mode, and doesnt work in manual.

Upd. Can’t clearly say what I’ve done, but now I can run this motor when i press “backwards” on the gamepad. Motor #2 works well in all modes, same as the rest motors


(Jacob) #4

Does the motor only run in one direction? Can you please take some pictures of the electronic speed controllers connected to the motor leads and let me know when you purchased the ROV?

Our previous ESC design was sent to us with single-direction firmware, and we needed to flash them in-house with reversible firmware. There have been some cases where some made it into ROVs without being re-flashed.

Our new ESCs are shipped to us with reversible firmware.


(Konstantin) #5

Well, checked ESC again. Looks like now it doesn’t work - LED indicator is off, so I think it means there is no power - so there is no any movement for now.
Also, only at this one ESC the red cable was not cut off - so I think this is right that case when I’ve got a native one-direction ESC


(Jacob) #6

Ok, can you please take a picture and send an email to support@bluerobotics.com to receive a replacement.