Home        Store        Docs        Blog

Vertical motor 6 does not work


(Maureen Byrne) #1

Whenever i move the throttle stick forward only the vertical motor 5 responds. I’ve tried flashing the latest firmware on to the pixhawk and downloaded the latest build of Q ground control and tried changing the directions for the parameters(Reverse/forward). I also changed both the motor 5 and 6 ESC, and there is no change. Vertical motor 6 only repsonds if i move the left stick up for the Roll.

Any suggestions to what i mught be doing wrong?


(Adam) #2

Hello Maureen,

I actually had this exact same problem myself yesterday while setting up an ROV at Blue Robotics HQ, and went through the same troubleshooting steps. It turns out I had the wrong firmware flashed to the pixhawk- the PX4-bluerov firmware is actually for the original BlueROV, not the BlueROV2. The BlueROV2 uses the PX4-vectored firmware. Can you make sure you have the proper firmware installed?

This should solve the issue!

-Adam


(Maureen Byrne) #3

Thats probably the mistake, I did not flash the vector file. I’ll let you know how it works out tomorrow!

 

Maureen