Home        Store        Docs        Blog

No Motor response after arming


(sriprada) #1

Hi,

I recently bought a pixhawk and i am trying to drive my ROV using it. I have few questions on first time setup:

  1. The first time i connected my pixhawk and uploaded simple rov firmware, all the modules in qgroundcontrol are shown as green indicators and is ready to arm.Is this normal as i didn’t calibrate accelometer, compass or my radio.

  2. Even with green indicators i re calibrated accelometer, compass and then the radio calibration everything worked fine.So after this i armed my vehicle but i see no output as my motors don’t respond.The pixhawk shows blue solid light which means its armed.I have checked my connections and everything looks fine. Is there any other calibration or any steps i have to follow before i arm my vehicle.


(sriprada) #2

I opened Mavlink inspector and checked for my RC Calibrated values and also checked the Servo output values before and after arming.I have attached the screenshots of the servo output values. I am completely new to this can you please help





(TCIII) #3

@sriprada,

Is your ROV configuration a BlueROV1 or a standard vectored 6 thruster configuration?

I have the standard vectored 6 thruster configuration and my second RC input is 1500 while yours is 960. The second RC input controls the speed and direction of the vertical thrusters in the standard vectored 6 thruster configuration.

Regards,

TCIII AVD


(sriprada) #4

Thank you TCIII for your kind reply,

I have used 4 motor driven SimpleROV configuration. The 5th and 6th servo output remains constant which i dont require. I made changes in my RC input and centered all the channels now, after arming in stable position i tried to tilt the ROV in the roll axis to check the response of the IMU, i see a slight change in horizontal motors while vertical motors remain constant, when i further increased i get a crash message. I don’t understand why horizontal motors respond to roll axis. I have set the motor channel according to numbering shown in ardusub simple rov frame.




(Rusty) #5

Hi Sriprada,

What are you using to provide input to the ROV? Are you using a gamepad controller or an RC radio?

Best,

Rusty


(sriprada) #6

Hello Rusty,

Thank you for your reply, I am using Logitech Gamepad to control my ROV. I initially thought that the IMU would respond to the roll axis, then after checking code for simple rov configuration i understood that it has not been done so.I compiled the code by setting the Vertical motors to respond to roll axis.But the problem now i have is that the yaw and the pitch response from my controller is not working properly.