Home        Store        Docs        Blog

First Dive issues


(Samir) #1

Hello,

On our first dive and post calibration once we got everything configured as indiciated, we observed a constant need for the BlueROV to do a front flip over and over when attempting to stablize. No matter how many times we calibrated the accelerometer and compass, we continued to observe this problem. We wonder if the control algorithm is going crazy for some reason. Would you have any insight on this?


(Rusty) #2

Samir,

Interesting. Are you sure the vertical motors are all spinning in the correct direction? Have you checked directions and reversed any incorrect motors as described here?

-Rusty


(Samir) #3

<hr />

Rusty,

Qgroundcontrol doesnt support the joystick though, its the message I always get on connection with the pixhawk.

Do I need to upload a different version of the firmware?


(Rusty) #4

Samir,

QGroundControl shows a warning that you need to have a vehicle that supports “MANUAL_CONTROL” messages for the joystick to work. The warning is attached.

This is completely normal and you can simply press OK.

Does the joystick show up in the settings panel once you connect to the Pixhawk?

-Rusty



(Samir) #5

Rusty,

Yes it did, so would I need to map the buttons then attempt to test the motor directions?

I thought I wouldnt be able to interface with the joystick due to our previous discussion using qgroundcontrol is all.


(Rusty) #6

Samir,

Are you talking about using QGC and ROS at the same time?

You should be able to test motor directions without mapping buttons at all. Just click arm at the bottom of the QGC window.

-Rusty