ArduSub 4.1.0 Thrusters not answering joystick commands

Hi,

I had some trouble on the field today with our BR2.
It connected fine to QGC and Joystick was enabled. “Arming” the vehicle worked, tilting the camera and turning off/on the lights worked fine too. But the thrusters didn’t respond at all. The commands for putting in “depth hold” or “stabilize” mode didn’t work either.

I tried all of this :

  • In QGC settings > Joystick settings : the little bars for throttle, yaw, etc. are moving when I move the two little joysticks. So I don’t think it’s a problem with our controller. I also tried putting in fresh batteries in the controller, but problem persisted.
  • In QGC settings > Motors : I tested all the motors individually, manually. They all work fine.
  • I tried rebooting the ROV (replugging the battery), but that didn’t do anything.

Also, I recently updated to Ardusub 4.1.0 because of a recent problem I had. This is the first time I tried using our ROV since the update.

More specs :

  • using a wireless Logitech F710 controller
  • QGC 4.2.3
  • Ardu Sub : 4.1.0
  • Companion : 0.0.31

How could I fix this problem?
Many thanks

I am having exactly the same issue here…

Update : I tried going back to the previous version of QGC that I was using : v4.0.5
Now everything works perfectly again.

I guess there is a compatibility issue between the new Ardusub 4.1.0 and QGC 4.2.3 (i had updated QGC because it was the latest recommended version on the BlueRobotics website.)

@luuckiest maybe this will work for you too?

okay, I am going to try that today.

Thanks a lot!!

At least there is some way of fixing it.

Hi @katlea and @luuckiest,

I believe we’ve had issues with this when ArduSub 4.1.0 ends up with parameters loaded from a previous version of ArduSub, but we haven’t yet determined which parameter is at fault. Interesting that QGC 4.0.5 seems to have worked normally for you.

Would you be able to see if motor control via the joystick works as expected using QGC 4.2.3 if you reset all parameter via the Parameters page? Doing so may also require specifying the lights channel and battery monitor type and whatnot as well, but should hopefully fix the motor issue.

If anything we expect 4.2.3 to be almost a requirement for using ArduSub 4.1.0 as intended, since QGC 4.0.5 is too old to know about some of the new parameters.

Hi,

Unfortunately I have the same problem as you all. In May 2022 I purchased the BlueRov for work, (Italian Maritime Firefighter) to integrate search and rescue operations. We succesfully completed the motor set up (Auto mode). When we tried the first dive in a controlled pool we couldn’t operate the thrusters with the Joystick (Logitec F310).

I tried all of this :

  • In QGC settings > Joystick settings : the little bars for throttle, yaw, etc. are moving when I move the two little joysticks. So I don’t think it’s a problem with our controller.
  • In QGC settings > Motors : I tested all the motors individually, manually. They all work fine.
  • I tried rebooting the ROV (replugging the battery), but that didn’t do anything.
    *After reading this forum I tried to install first the version of QGC v4.0.5 but it was showing problems with compass parameters and then the version v4.2.2 but we couldn’t solve the problem.
  • I tried to install older versions of Ardusub as well but still the thruster didn’t move.

Ardusub version: 4.1.0
Companion version: 0.0.31

In my case through the Joystick I can operate the lights, tilting of camera, gripper, arming and disarming, manual mode, stabilise mode, hold depth.

We are really stuck here and need some help.

Thanks a million

Lorenzo

Hi @Cocis, welcome to the forum :slight_smile:

As above,

Thank you very much for your help.
After following your instructions the thrusters worked and we maneged to do the first dive which went well. Only the stabilze mode and depth hold mode made the ROV spin around. I ll have a look on this very helpfull forum to try and fix those.

Thanks again

Lorenzo

1 Like

Great to hear! :slight_smile:

Hopefully you managed to find the solution from your searching :slight_smile:
If not, have a look at this post and follow up if you’re unable to resolve the issue.

Thank you very much. This forum is very helpful and I managed to solve the problem. After I restore the parameters to default I didn’t noted that the roll90 option for autopilot was set to none.

Thanks

1 Like

Hello @EliotBR ,
I just tried this again (latest recommended QGC version + latest stable Ardusub) and the same problem still occurs. I tried Resetting the parameters through QGC, but that didn’t work.
Any other ideas?

A post was merged into an existing topic: WaterLinked DVL A50 integration not working