Home        Store        Docs        Blog

Manual mode working fine, depth hold and stabilize does not


(Robert Førland) #1

Hi,
I was testing a BlueRov2, with six thrusters, yesterday and everything worked fine in manual mode, but when I tried stabilize or depth-hold, the ROV went “crazy” and multiple thrusters just started blowing.

When I test on land, the stabilize mode makes one of the vertically thruster blow upwards and the other downwards. Depth hold just makes them both blow upwards. Nothing happens to the horizontal thrusters. I have checked the Motor Setup in qGroundControl multiple times and everything looks fine to me.

qGroundControl and Pixhawk should be up to date.


(Bo Koppel) #2

I had same problem, check motor direction setup, search in this forum


(Oystein Skarholm) #3

As long as the ROV is responding in the correct manner in manual mode the thruster orientation should not be the problem. As Robert explains, one vertical is pushing up and one is pushing down in Stab mode and both pushing upwards in Depth hold mode. Sounds like a bug


(Robert Førland) #4

Thanks for replying!
Yesterday I fixed the issue!
I don’t know exactly what fixed it, but I saw that some of the thrusters were placed in the wrong places, so I swapped them around and downloaded the default parameters. This still made it go crazy, but then it worked by just adjusting the motor directions.


(Oystein Skarholm) #5

Ok
So now its working. very nice. So a combination of wrong motor position when compared to the wiring diagram and wrong motor orientation, sounds like limbo dance.