Home        Store        Learn        Blog

Waiting for the vehicle connection

Hello,
I have a BROV2 that has not been connected for a long time. Recently, I reconnected it and found that only the video output could not be connected successfully.
When I connected the power, I found that the ROV only had 3 short ringtones.
Pixhawk lights are two power lights on green, power B/E lights off, the other B/E lights on orange, act lights on blue (feel frequency less than 1s each time).


This troubleshooting guide is a good reference: Troubleshooting · GitBook

Hi @Kingzeon,

This means that the ESCs are detecting the motors, but that they’re not getting a valid signal from the Pixhawk. Do you know which versions of ArduSub and the Companion software you’re using? You can check on the System page of the Companion Web Interface. It could also be useful to know which version of QGroundControl you’re using.

As @CBW3750 mentioned, our troubleshooting guide is a good starting point - especially the section on Waiting for Vehicle Connection :slight_smile:

I used a USB cable to connect directly to pixhawk, and then flashed 4.0.3 in QGC, and the flashing was completed, I connected to 192.168.2.2, and found that ArduSub showed not found and the Companion version was 0.0.28. This shows that pixhawk appeared Is it malfunctioning? I tried formatting the internal memory card and then re-swiping it in with 4.0.3, the same effect was still achieved.

Did you reconnect the Pixhawk to the Companion computer before trying this?

If the web interface System page is showing the Pixhawk1 in the Detected Devices section, and showing 4.0.3 as the ArduSub version then that sounds like it’s operating normally, in which case you should verify QGC autoconnect settings, check MAVProxy, and possibly reset MAVProxy options and try restarting your computer, all of which are suggested in our troubleshooting steps.

If those aren’t helpful please send a screenshot of the System page from the Detected Devices section down to the ArduSub version section, and another screenshot or code-block of the output of the Check MAVProxy step :slight_smile:

Do you know which QGroundControl version you’re on?

“Before trying this operation, did you reconnect Pixhawk to the Companion computer?”-I reconnected to QGC, and still let me update directly.
The system page only shows that the serial connection has pixhawk1, and the ArduSub version at the bottom of the system page shows notfound, that is, the version number is not displayed. QGC uses 4.0.5.
QGC’s automatic connection is no problem, because I can connect to other ROV2.
The MAVProxy settings are as shown in the first post, but after I re-flashed pixhawk, it showed that MAVProxy was not found.

Your first post showed the detected screen sessions, which lets us know that the ‘mavproxy’ screen session is running, but doesn’t tell us anything about the MAVProxy settings. I’d suggest you try going to the MAVProxy page of the companion web interface and press the “Restore Default Options” button to reset the settings :slight_smile:

I pressed the “Restore Default Options” button, but it didn’t respond afterwards. When I used the method of the first picture to view, it said I was not connected or MAVProxy was not found.

I’m not entirely sure what’s going on here, and without screenshots it’s a bit hard to tell exactly what you’re referring to. Restoring the default options should make it so that it’s able to detect the Pixhawk again, but if something went wrong in the initial update process to 0.0.28 then it’s possible your companion computer doesn’t have a working mavproxy on it.

If you originally updated companion to 0.0.28 through the web interface, could you try instead directly flashing it onto the Raspberry Pi SD card, to make sure it’s set up correctly/includes all the required components?

Below I will upload a few screenshots for you, I hope you can help me! Thanks!



There’s definitely something wrong here - the Active Services should show the same list of things as the screen -ls from your first post. It also isn’t showing video or audio devices, but your first screenshot clearly showed a camera connected and working. Are you able to flash on a fresh companion software, as I suggested/linked to in my previous comment? :slight_smile:

Does it mean I want to use the latest version of QGC?

Please try directly flashing the 0.0.28 companion software onto the Raspberry Pi SD card (not the Pixhawk one), using the Etcher application, following the instructions specified in the first section of this link.

This is unrelated to QGC, because if the components aren’t correctly running on the companion computer then they won’t be able to communicate with the top side at all. If you’re on Windows you can also update your QGC to 4.1.4 if you want, but that’s unrelated to the issue we’re discussing here, and you will still need to flash the companion software.

I did not find the SD card slot of the Raspberry Pi. Do I need to transfer the SD card to USB and then connect it to the USB card slot?

It’s underneath it, as shown here:

If your computer has a microSD slot then you can connect to it directly. If not then you will need to use either a microSD to SD adaptor and plug it into an SD slot (if your computer has one), or you can use a microSD to USB adaptor and plug it in to a USB connection :slight_smile:

I found it. Can I use the memory card on the Raspberry Pi directly?

That’s the one that you want to flash over with the companion software, yes. Once that’s done you can plug it back in to the Raspberry Pi and it should work like normal :slight_smile:

Hello EliotBR,

I swiped the SD card of the Raspberry Pi according to your method, but the situation is still the same as the original screenshot I gave you yesterday.

When I checked mavproxy, the situation as shown in the figure below appeared

This seems to be indicating the Pixhawk isn’t responding as expected. If you connect the Pixhawk directly to QGC does it still get detected? If so, does it come up as ArduSub and version 4.0.3?

No, it will appear as shown in the figure below.