Home        Store        Docs        Blog

"Vehicle is not responding" error message

(Earl Chapman) #1

My ROV build was going well and completed first wet test earlier this week. Everything was working but when rebooted last night, it would not connect and QGroundcontrol shows error message “Vehicle is not responding…etc”. Says to reboot vehicle and restart QGroundcontrol, which I’ve tried several times with no luck.

Main LED on pixhawk does not light, so I re-flashed with several other arudpilot flight stacks and it seems to be fine, but when re-flashed with ardusub flight stack, back to “vehicle is not responding” and no main pixhawk LED. Have pulled pixhawk out of ROV build and connected direct to computer via USB but still no luck connecting so I’m concentrating on PIXHAWK.

At one point in the debug had “could not detect BRD_TYPE” error message, but cannot replicate.

Any advice on next troubleshooting steps would be much appreciated. Thanks in advance.

0 Likes

(Willian Galvani) #2

Hello, what version of QGroundControl and Ardusub are you running?
For now you should be using QGroundControl 3.2.4-rev6 and Ardusub 3.5.3

0 Likes

(Earl Chapman) #3

Hi Willian,

Thanks for the response. I uninstalled all versions of QGroundControl and installed only 3.2.4 from GITHUB (could not tell if it’s Rev 6). Reflashed PIXHAWK with Ardusub 3.5.3 (which is what I’ve been using all along).

Same error message (“Your vehicle is not responding…etc”.

Any other suggestions?

0 Likes

(Willian Galvani) #4

For the record, you should download QGroundControl from here. But it really seems like something is wrong with your pixhawk. Have you tried formatting the Pixhawk sd card too?

0 Likes

(Earl Chapman) #5

Hi Willian,

Yes I tried reformatting the pixhawk SD card too (actually, I reflashed it using the BalenaEtcher software I used on the Raspberry PI card. Is that the same?). The part that still keeps me from giving up on it is that when I flash the pixhawk with one of the copter stacks, it seems to work.

0 Likes

(Willian Galvani) #6

The SD card in the Pixhawk should just be formatted clean, not with the companion image, that one is for the Raspberry Pi.

0 Likes

(Earl Chapman) #7

I misunderstood. I tried that too. Formatted as FAT32. Is that OK?

0 Likes

(Jacob) #8

Yes, this is the correct format for the pixhawk sd card.

0 Likes

(Jacob) #9

This sounds like it could be a problem with the bootloader revision. Please let us know, which copter version is working, and where/when you purchased your pixhawk.

0 Likes

(Earl Chapman) #10

Hi Jacob,

When I run the PIXHAWK Flight Stack into the PIXHAWK, it seems to work. I don’t have the airframe, but I can get all the way through all the calibration steps and the main LED comes up blue. When I go back and try to change to ARDUSUB, I get the “cannot connect” error message.

0 Likes

(Earl Chapman) #11

Jacob,
Not sure if this helps with advice on debugging, but I was sitting here trying to figure it out and decided to load the ARDUPLANE onto the PIXHAWK. It came up with an error for BRD_TYPE not detected but did load, so I went into the BRD parameters and manually changed it from AUTO to PIXHAWK. Everything worked. Was able to calibrate the pixhawk, connect up Real Flight simulator controller and far as I could tell, all was good. I then tried to load ARDUSUB and still had the same error message as before “Your vehicle is not responding. If this continues…etc”. After unplugging, rebooting, restarting QGroundcontrol the same error message comes up.

0 Likes

(Jacob) #12

It sounds like there is no sd card in the pixhawk.

0 Likes

(Earl Chapman) #13

Hi Jacob,

Confirmed the SD was in the slot (16GB). For the heckuva it, I reformatted (FAT32) and reinstalled in Pixhawk and same error in QGroundcontrol. When I checked the card aftwerwards, it has an APM folder, so I’m assuming this means QGroundcontrol Firmware task recognized it.

0 Likes

(Jacob) #14

Please do this:

  • unplug pixhawk
  • uninstall qgc
  • install qgc from here
  • format sd card fat32
  • put the sd card back in the pixhawk
  • attach the pixhawk by usb and install stable ardusub (3.5.4)
  • unplug and plug back in the pixhawk by usb
  • what does the large center led on the pixhawk do? what does qgc do?
0 Likes

(Earl Chapman) #15

Thanks Jacob.

I went through all the steps. Large LED in center doesn’t come on. Small amber and small blue LED’s on top right of pixhawk flashing. Same error message in QGroundcontrol. About ready to give up. Frustrating for sure as it was working fine and still appears to load the multirotor stacks.

0 Likes

(Jacob) #16

The only way that I can reproduce this on v3.5.4 is to take the sd card out of the pixhawk. The older firmware will not boot (no RGB led activity) without an sd card. Newer firmware versions (like copter and plane) will boot without an sd card.

Please click Advanced Settings -> Developer build (master) -> ardusub v3.6.0 dev and load that. I think you will find that this one works (but it’s not stable yet, so only use it for testing).

It sounds like your sd card slot or sd card is broken, but the fact that the autopilot wrote an APM folder is in contradiction with this conclusion. Maybe it’s a transient connection issue?

0 Likes

(Earl Chapman) #17

Thanks again for taking your time to help me through this.

OK. Tried this, but it ended in the same spot.

Still same error message. On Pixhawk, the main LED still doesn’t come on, but the small amber LED is solid now vs flashing. Small blue still flashing. Both of the green PWR led’s are on.

For the heckuva it, I loaded the master build for the PX4 Flight Stack and it seemed to work fine. Went into summary and was able to calibrate the sensors. Did same with ARDUROVER Dev 3.6.0

0 Likes

(Jacob) #18

@earlchap Did you actually flash ArduSub-v3.6.0 to the board? In your screenshot, it looks like you have prepared to do so, but stopped short when the yellow message came up. Go ahead and ignore the yellow message and try to get ArduSub v3.6.0 on that board.

0 Likes

(Earl Chapman) #19

Sorry. I did flash and try it. Screenshot was from the 3rd or 4th try to show which version I selected.

0 Likes

(Jacob) #20

Did the messages in the window indicate that the flash of ardusub-3.6.0 was successful?

0 Likes