Home        Store        Learn        Blog

Waiting on Connection HELP

I purchased the Advanced Electronics Kit, and have everything hooked up for a custom body, heavy 8 thruster configuration. I am able to get video with QGround Control, but am not able to make a connection to my Pixhawk. I’ve tried all of the trouble shooting tips, and have had no luck.

My Ardusub version is “Not Found”.

My active services and detected devices look good from what I can tell.

How do I tell if my Raspberry SD card is flashed correctly? Could that be an issue?
Please help! I need to finish this project ASAP.

Thank you,
Ryan

1 Like

Hi!

Is the pixhawk detected in the system page as a usb device?

This is what my system page shows:

@williangalvani I was going through the setup process and it lost connection. Now I can’t get the Pixhawk main LED to come on = Waiting for Connection error again in Ground Control.

can you try connecting the pixhawk directly to your computer to check if it is working properly?

Connected to computer I have the Green FMU Power light, Green IO power light, and flickering Orange IO B/E light.

@manningry

Im not getting anything from mine either, I did go and flash my sd card anyway while waiting on a response, link I used is below.

Still waiting on connection from vehicle but also have a call open to try and resolve.

Currently working through this vehicle connection problems using link below

@manningry @Blizzard257

Are your Pixhawks from recent orders?

Can you test flashing Ardusub 4.0 via QGC connected to your computer instead of the raspberry? Ardusub 3.5 doesn’t run if it doesn’t detect a sd card for some reason.

@williangalvani My Pixhawk is from a recent order – maybe 3-4 months. It came with the Advanced Electronics setup pacakge.

I just flashed the Pixhawk via QGC :

@williangalvani

Mine was delivered last week.

Tried putting the sd card from pixhawk into the usb to flash but in QGC i wasnt able to select the start from the program but will try again

@Blizzard257 Does your Pixhawk look like this?

@manningry

Yes it does, did you plug the controller directly into the computer?

Thanks for sending those links over too-- I was going through the guide in the meantime as well. Try and diagnose what could be happening. I switched my micro-usb from the Pi to the Pixhawk thinking maybe that was an issue as well. Nothing.

I did get everything to work earlier this morning – lights on the Pixhawk, connection to computer, and was in the middle of programming motors when it disconnected and reverted me back to square 1. :confused:

@Blizzard257 I plugged the Pixhawk directly into the computer and used the QGC to flash firmware onto it. But then unplugged and plugged back into the Pi, unplugged the battery, and reconnected everything.

@williangalvani @manningry

Both flashes completed successfully as connected directly from pixhawk.

Still waiting for vehicle connection

@Blizzard257 Just chatted with Willian and he thinks my Pixhawk is defective.

@williangalvani I just sent an email to support asking for a replacement. Apparently I’m also on my maximum number of responses for the day on here.

_______________________________________________________–

@Blizzard257 I just got mine to connect! Experiment with what you flash the Pixhawk with. Unplug everything from it, and connect it to your computer via USB. Go to the QGC–>firmware–> Try flashing it with Beta versions of the Chibi-OS–>SUB–>Pixhawk1 & Pixhawk1-1M. I cant remember which one worked but somehow everything is working.

1 Like

@manningry

Thanks for update, I’ll give my distributor a shout in the morning and see what they say.

Maybe a faulty batch

@manningry

Don’t know what I’ve done either, just kept plugging things out and back in, Pixhawk now connected direct to laptop with lights and 5v cables disconnected. tether usb connected to other usb port and they now seem to be speaking to each other. Although I need to calibrate accelerator then the compass. I could re-flash but last time I used pixhawk1, this time round I dont have a selection?

reconnect everything up as it should be and unable to to talk to each other again.

@williangalvani Thanks for support earlier