Home        Store        Docs        Blog

Ardusub version?

Hello all, I need some help.
I have an issue which happened since last week.
I lost connection from ROV it is showing "waiting for vehicle connection "
When I checked On web browser ardusub version not present…like below picture


Trying to update firmware by web browser By upload and stable function also not succes. On text box below always showing like below picture

I try update by QGC result showing like below

Anyone has the same problem and success to solve the problem please if you can answer my question, it is urgent since i used rov to help my job.
I also trying to uninstal and reinstal QGC not success.
I try also to reflash raspbery firmware he same not success. Trying on different laptop the same.
I have no idea what to do anymore…

Hello @erik1,

Did you get it working?
Have you tried with a daily build of QGC?

Hi willian,

Thanks for reply.
I was not lucky my Rov still not working.
I have no idea why.
as you see on my picture,the pixhawk when i try to update always waiting bootloader either by web browser or by QGC.
On web browser i dont see version…
is the pixhawk damage ???

Did you try the daily build?
That is Odd. The “Not Found” means that the Pixhawk is not booting properly and there is no Mavlink communication.

QGC is detecting it but is unable to talk to the bootloader, which hints that either the Pixhawk is malfunctioning or QGC is unable to talk to the bootloader for some other reason.

Were there any changes to your setup before the issue started?

Here are some things you should try:

  • Change the usb cable to the Pixhawk
  • Use QGC Daily build
  • Flashing with another computer

Hi
Thanks for quick response.
I did all that 3 thing and still not working…
I I flash companion sd card and also sd card inside pixhawk still the same problem
At the end always come to the same messages if waiting bootloader.
Thanks appreciate your suggestion

The sd card in the pixhawk should be blank, formatted as FAT32. You should not write any file to it. Are you still having problems?