Ardusub Firmware Uploading Failed

Hello everyone,

I tried to update the ArduSub Firmware on our ROV through the companion computer web interface, but failed. Now when I try to upload firmware file, it always stucks at the “waiting for bootloader” on the companion computer web interface, the Lights on the blue ROV keep on when powered, and the B/E LED under FMU on the Pixhawk hardwared keeps on constantly. Does anyone know what I should do now? Thanks in advance!

I first tried with just clicking the stable option under ArduSub Firmware but it kept saying having no internet connection, which it truly had. Then I found this post saying there’s a bug with SSL check: ArduSub firmware update failing - SSL . So I decided to download and upload firmware file. I used the firmware file from here: . It started writting the firmware file to pixhawk fine but it then failed when loading “data” till 86% (Sorry I don’t have a screenshot of it) . When I tried again, it always stuck at “waiting for bootloader”. I waited for about 1 hour and It was still waiting forbootloader. Then I power cycled the ROV, but it was still the same and the behavior described in the problem section occurs.

I found this post from ardupolit saying if the B/E LED under FMU goes on constantly, it means an error with Pixhawk’s bootloader. Pixhawk LED Definitions? - Archive - ArduPilot Discourse .

Really appreciate if someone can provide some help, thanks in advance!

Hi @hjz_123,

If a Pixhawk update fails it ends up with no functioning autopilot firmware, so turning it on just loads its bootloader, fails to load a valid firmware, and waits around for communication. Our old Companion Software is not able to do anything about that, so your options are either

  • Install a recent beta release of BlueOS onto your Onboard Computer, and select the bootloader on the Autopilot Firmware page, then perform a normal ArduSub firmware install
  • Connect the Pixhawk directly to a computer running QGroundControl (via the micro-USB port that normally connects it to the Raspberry Pi Onboard Computer), and use QGC to perform an ArduSub firmware install
    • I would recommend updating to BlueOS in general, since our old Companion Softrware is no longer being maintained, but using QGC to only update the autopilot firmware may be necessary if you currently have custom code running on your Onboard Computer