Home        Store        Learn        Blog

QGroundControl: No Telemetry / "Waiting for Vehicle Connection" issue

Hi all!

I’m still having the “No Telemetry / “Waiting for Vehicle Connection”” error on my windows computer with QGroundControl ( v4.0.5 ) installed, Companion ( v0.0.26 ) installed on the Companion Computer (Raspberry Pi), and Ardusub ( v4.0.3 ) installed on my Pixhawk. I verified that the network configuration for the Ethernet IP address was 192.168.2.1 with the subnet mask 255.255.255.0.

I still can’t ping 192.168.2.2. I shut my firewall off, rebooted the laptop multiple times, and verified QGC Autoconnect settings. I know that the ArduSub USB Connection is working properly because I connected to the Pixhawk through a MacOSX. Has anyone had this issue or have thoughts on a solution?

1 Like

I’ll assume you have been through our Troubleshooting Guide

Was this through the FXTI? that would help narrowing down the issues.

Are the “link” lights on on both the rov and FXTI?

Good idea! I checked the “link” LEDs on the FXTI system and both were lit.

Hi Cameron
I did have same problem and problem was solved when I changed the SD card in Companion computer and downloaded new sw for it.

// Bo

1 Like

Thank you Bo! I checked that QGroundControl, Companion and ArduSub software were up to date and they were. Somehow, after my Windows laptop did another series of updates I finally got connected to the BlueROV2.

-Cameron

1 Like