Home        Store        Learn        Blog

Companion is working but no link with Qgroundcontrol

Hello,

Companion is working through http://192.168.2.2:2770.
I can see all information on my PC (all active services working on Raspberry Pi 3B are displayed).
But when I run Qgroundcontrol I have no link. Waiting for connection with Vehicle.
I do not understand.
If I connect Pixhawk directly via USB, it is working and input and output validated (working).
Thus I connect the Pixhawk to the Raspberry pi 3B via USB and my PC is connected to the RasPi via Ethernet cable.
Directlink with http://192.168.2.2:2770, companion is working.

Any help how to setup Qgroundcontrol to have a communication with the Raspi ?

Thank you in advance for your help.

Best regards.

David

Did you check your firewall settings?
Allow an app through firewall … -grant QGC permission for both public and private networks

Hi @DB_2020ROBOTICS, welcome to the forum :slight_smile:

Have you gone through our software setup guide? As @cbusse1 mentioned, it’s possible/likely this is a firewall issue.

If that doesn’t help, try going through our troubleshooting guide.

Hello

I made more tests yesterday

I can ping the RasPi 192.168.2.2 from PC.

When I start the RaspPi I have this message :
“onpening /dev/serial/by-id/usb-ArduPilot_pixhawk1_26004E000951363231333636 -if00 @115200 bps
An exception has occured : Failled to open the given Serial port (32, ‘broken pipe’)”

But when I type the command lsusb I can see that the Pixhawk is connected (line disapears when pixhawk not connected).

More details :
I can ping the Raspi from PC 192.168.2.2, but Raspi can not ping the PC 192.168.2.1. Why ?

Thank you in advance for your help.

Bets Regards;

Hello

Yes I verified our firewall and we also stopped the Antivirus.

Watching this post as we are experiencing similar issue. RaspPi is sending back signal but QGroundControl has no link to Pixhawk and we are not able to control the ROV what so ever.

Hello ! I encounter issues with QGroundControl

I connected a raspberry pi 3b to my laptop (with windows 10), using a straight ethernet cable. The raspberry is connected to a Pixwhawk 4 with an USB connexion. Everything is well powered, the raspberry can communicate with the Pixhawk.
But QGroundControl doesn’t recognise the raspberry, it’s « waiting for vehicle connexion ». I have already checked the troubleshooting section but it doesn’t solve my issue…

Can you help me ?

Hi @2020Robotics, welcome to the forum :slight_smile:

Have you followed our software setup guide?

This is difficult to work with. Did you try every step in the troubleshooting section? If so, what were the results? Were you able to ping the companion computer? Have you disabled any relevant firewalls/firewall components? And so on

Hello, thanks for your answer

I have followed all the troubleshooting « QGC waiting for connexion » section, my network config is good, my firewall allowed QGC on the laptop, I tried with 2 differents straight ethernet cables, I rebooted the RasPi and the surface computer many Times, configured QGroundControl as it was showed, and ensured that the system page is working (typing http://192.168.2.2:2770/system on a search motor) and mavproxy was indeed linked with autopilot.

When the Px4 is connected with the USB cable to the computer, QGC immediatly recognise it. I also recreated the SD card on the ardupilot website 2 times… Nevertheless, i have an error message when I switch on the pi (which occure only when the pixhawk is connected to it), which says : « An exception has occurred: Failed to open the given serial port: (32, ‘Broken pipe’) ». The issue seems to provent from the USB port of the pi (I precise that I tried the 4 of them). Using the lsusb command, I discovered that the pi recognise the pixhawk as « Blus 001 Device 004: ID 0483:5740 STMicroelectronics STM32F407 ».
Do you have a solution ?

Furthemore, I can ping the pi from my PC but I can’t ping the PC from the Pi. Is this a problem ?

This seems to be happening pretty common, as I’ve counted 3 occurrences (including myself) in July. Could we maybe have a Zoom debugging session that we can discuss/debug real time? Feel that could be helpful in addressing this issue.

Are you able to use QGroundControl to update the PX4 firmware to ArduSub with ChibiOS? We have tested and confirmed the PX4 should be able to run ArduSub, but have only extensively tested and used the Pixhawk 1, so there may be some configuration issues here that we don’t normally run into. I believe the ‘board type’ you want is fmuv2.

Once you’ve done that it would be great if you could plug it into your companion computer, then connect to your surface computer and access the companion web interface. I’m particularly interested in whether the System page displays meaningful information in the ‘Detected Devices’ and ‘Pixhawk Firmware Update’ sections.

Hello everybody

I tried with an another PC and QGroundControl is now communicating with PaspPi.

I will reinstall windows on the first PC and I will keep you in touch.

Best Regards.

1 Like

I believe my issue is the same as mentioned above. I have tried 3 different computers. I have done a resistance test on the umbilical and i have removed individual thrusters from the system, powering up each time to check if the problem was resolved. I have video but do not have a connection to the vehicle. I also have 2 seperate surface interfaces that ive interchanged to see if that was the issue. All firewalls are disabled on the computer.

Hi @darren.horler,

Have you looked at the troubleshooting guide I linked to in my first comment here? It includes multiple checks that you haven’t mentioned doing, so I’d suggest you try those if you haven’t already, and report the results of them if you have :slight_smile:

I was in the middle of a project and switched batteries when i repowered i no longer had the ability to arm the vehicle. Since i have brought it back to the shop to check it all out. I have a spare Fathom-x topside interface that i tested with. I had two separate laptops that worked prior to this issue that i tested with. I disconnected all the thrusters and aux individually and tested. I removed Qground from one of the computers and followed the software setup instructions from scratch and tested. I used a muti meter and tested the umbilical and it is good. I have run out of ideas. Can anyone suggest something i have not tried? Thank you in advance for your time.

In our case, As I said we stopped the Firewall and Antivirus AVG and we still had the problem.

I completly disinstalled the Antivirus, and it was magical, communication between PC and PX4 through Companion is working and the Full HD video also.

I tryied with Kaspersky Cloud antivirus and it is working.

Disinstall AVG if you have it.

Best Regards.

David

1 Like

i have taken this suggestion and removed the expired Mcafee anti virus from the computer. I have no antivirus program on the computer and have allowed both private and public access to QGC in the windows defender firewall. This still has not resolved my issue. I have carefully followed the software install instructions and even wiped QGC from one of the laptops and started from scratch. However ,I have not directly connected to the vehicle with a USB as i have seen in some of the other comments.

I’m not sure if it is relevant, but when i try to run QGC in safe mode i don’t get video, as i do in compatible mode.

In companion Network Connected ,Test
Upload - 41.731 Mbps
Download - 42.044 Mbps
I have opened the system:
Active service - mavlink2rest ,bridgmanager, wldrive, nmearx, file-manager, audio, commrouter, webterminal, webui, video, mavproxy
Video device - H264_USB_Camera
Audio device - H264_USB_Camera
Serial device - Pixhawk1
companion Version - 0.0.22
ArduSub Version - Not found
I did a download and update of the stable
log:
Downloading stable ArduSub firmware from https:…
[Errno 28] No space left on device
error downloading firmware! Do not have an internet connection? Try ‘ping ardusub.com

Does this explain any issues i may have?

Ive now done a Restore Default Firmware
this was successful in Erase , program, and verify. It then rebooted. I attempted the stable download again with the same results of [Errno 28] no space , and no internet connection. I have tried a different USB from my computer to the FXTI. I will need to go purchase a USB that will go directly from my PC to the ROV. I am not exactly sure if i connect to the side of the pixhawk from the PC or to the board under the Pixhawk with the SD card in it. Ill purchase both and wait for a response before attempting. I may also find a different internet connection as this one has been temperamental. I greatly appreciate any help anyone can give me. Im sure it is apparent by now that I am not very experienced with this system and i apologize if this trivial stuff or things i should be aware of. As i acquire knowledge i will contribute as much as i can back to the forum.

The ‘no space left on device’ issue is a problem with companion versions before 0.0.23, where mavlink logs build up and take up too much space to update. If you use the companion web terminal you can run rm -r ~/telemetry to delete those logs, and should have enough space.

The ‘do you have an internet connection’ error message is a suggestion because the firmware failed to download, although in this case that’s more likely from the ‘no space left’ issue.

If you actually haven’t connected to wifi you can do that from the Network page). The upload and download tests from that page are between the companion computer and the top computer, and are unrelated to wifi.

You mentioned you followed the software setup instructions from scratch, so I’m confused as to how your companion computer is on version 0.0.22 (the latest is 0.0.26). Once you’ve connected to wifi could you try updating both companion and ArduSub from the System page?

Just for posterity, if there’s wifi near you but no options are appearing in the Wifi SSID dropdown then you’ll need to flash the latest companion software directly onto the Raspberry Pi’s SD card instead, after which you should be able to connect to wifi and update ArduSub. There are instructions for that here. The note at the top of that page which says “The latest version of Companion is v0.0.22” is out of date and can be ignored (we’re considering making the note auto-update but haven’t managed to yet) - the download link in the numbered steps is correct for the actual latest version (currently v0.0.26).

If we can’t help new users then our user-base won’t last. No need to apologise - you’re clearly trying to follow our steps correctly and something still hasn’t worked, which generally means we need to improve either our instructions/documentation or software. We’re working on both at the moment, but while there are issues they can be discussed on the forum - that’s part of what I’m here for, with help from the community members who’ve dealt with similar issues, and when need be the relevant software or design engineer(s) :slight_smile:

That’s the hope. A community working together to build shared knowledge is much stronger than one with fragmented repetitions of the same questions and responses :slight_smile: