Home        Store        Learn        Blog

QGroundControl to Raspberry Pi 3 connecting issue

Hi,

I am conducting bench testing of the Pixhawk 4 (ardusub current beta) <- serial (working) - > Raspberry Pi 3 (raspbian)<- Ethernet (not working)> QGroundControl. I configured the Pi 3 myself and would like to try and figure out the issue for my own development as I am very new to networking etc. I have modified rc.local file to have mavproxy start on the pi 3 booting.

I run sudo -s to access the pi 3 root and then sudo -x shows the following:

Connect /dev/ttyAMA0 source_system=255
no script MyCopter/mavinit.scr
Log Directory: MyCopter/logs/2019-12-07/flight10
Telemetry log: MyCopter/logs/2019-12-07/flight10/flight.tlog
Waiting for heartbeat from /dev/ttyAMA0
MAV> online system 1
MANUAL> Mode MANUAL
APM: ArduSub V4.0.0beta1 (a8f250c9)
APM: ChibiOS: 0997003f
APM: Pixhawk4 0023001F 31385116 35333837
Received 902 parameters
Saved 902 parameters to MyCopter/logs/2019-12-07/flight10/mav.parm
no link
link 1 down
link 1 OK
heartbeat OK
MAV>

What must I do to get QGroundControl to work with the Pi? I have tried everything on the MavProxy site, udpbcast, udpout etc on both desktop and Pi and I am now lost. I have connected the Pixhawk 4 directly to QGroundControl via USB and it connects automatically with no issues.

Mitch

Hello @mitch.batty,

What is your networking setup and how are you launching Mavproxy? which arguments?

I just managed to rectify my issue. I had an error in how I had set the static IP on the pi which I hadnt checked. The IP was correct, I had eth0 commented out. Now all telem can be viewed throught the Mavlink Console in QGroundControl. Thanks for your help