Home        Store        Learn        Blog

Unable to connect to unit through QGroundControl

Hi,

I’m using an iMac, or macbook, to connect to the ROV, purchased in August 2019 but only assembled in the last week. I start up QGroundControl and get nothing: “Waiting for Vehicle Connection”.

Details:
-I’ve changed the USB connection to the specified IP addresses in the network settings. No firewalls.

-QGC Autoconnect settings are as specified in the ardusub troubleshooting doc. Though I note that in their screenshot that “Pixhawk” isn’t ticked?

-I can ping 192.168.2.1 and the pings return fine with no packet loss. I can connect to the companion computer through http://192.168.2.2:2770/system, I’ve connected the unit to wifi, downloaded Companion software etc. The active service list seems fine. The detected devices are the camera and “Pixhawk1”. The guide says it should say “Pixhawk Autopilot”?

-I’ve tried two different computers (iMac (High Sierra) and Macbook (Catalina)). Tried two different USB connectors.

-Tried pulling the electronics out and connecting directly to the Pixhawk. I’m not 100% sure I did this correctly. There’s a micro-USB on the Pixhawk itself, and one on the board that the Pixhawk is mounted on. I’ve tried connecting to both of them. On QGroundControl I’m still getting nothing. “Waiting for Vehicle Connection”.

Would anybody be able to offer suggestions? I’m happy to provide screenshots or any other details that might be helpful.

Thanks
Dean

Having similar issues:

QGC: 4.0.5
Companion: 0.21
Ardusub: will only connect if I revert to 3.5.4, when the latest stable version is flashed it acts as you describe.
I tried debugging per this: https://www.ardusub.com/troubleshooting/troubleshooting.html

Everything looks good but when I putty in, it fails the “screen -r mavproxy” test.
I also noted it says only pixhawk1 and not autopilot.
Thanks,
Jim

Update: My issue seems related to the 0.21 release of Companion. I reverted to 0.20 and was able to run the latest Stable version (4.0.1) on the Pixhawk. Not sure what the issue is but will keep an eye out for updates.

Thanks,
Jim

Thanks for the reply Jim, good to know you’ve got yours back to working.

I’m happy to try 0.20, do you know where I could download it from? Github only has the current version.

Thanks
Dean

I happened upon a link to it in the forum:
https://s3.amazonaws.com/downloads.bluerobotics.com/Pi/0.0.20/0.0.20.img.zip

Thanks, I’ve just tried to upload that zip file, and after it uploaded got the message
“validating archive
Archive does not look like a companion update!”

It said to upload zipped updated, so I’m assuming it should have been zipped.

You have to flash the SD card on the Pi using Etcher. https://www.balena.io/etcher/

Thanks, I’ve got no idea how to do that, I haven’t done anything with Pi’s to this point, guess I’ll have to figure it out! I assume it’s just a matter of popping the microSD on the end? Running Etcher seems simple.

Thanks for the help.

This is concerning. Have you already solved the issue? If, not, could you paste here the output of http://192.168.2.2:2770/mavproxy ?

@Dean.C you can find instructions on Etcher here.

Had to get it back up so I reverted to 0.20 on the companion, I could only get 0.21 to work with 3.5.4. Next time I’m in the bottle I can try to capture the output.
Jim

No problem. If someone else runs into it, please paste the output of http://192.168.2.2:2770/mavproxy here. Resetting the mavproxy settings at the same page might fix your issue, too.

I haven’t gone back to 0.20 yet.

Output from http://192.168.2.2:2770/mavproxy is:
–master=/dev/autopilot,115200
–load-module=‘GPSInput,DepthOutput’
–source-system=200
–cmd=“set heartbeat 0”
–out udpin:localhost:9000
–out udpbcast:192.168.2.255:14550
–mav20
–aircraft telemetry
–streamrate 10
–out udpout:localhost:9002
–out udpin:0.0.0.0:14660

Output from screen -r mavproxy is:
/dev/autopilot

Connect /dev/autopilot,115200 source_system=200

Failed to load module: No module named terrain. Use ‘set moddebug 3’ in the MAVProxy console to enable traceback

Failed to load module: No module named adsb. Use ‘set moddebug 3’ in the MAVProxy console to enable traceback

Listening for GPS Input packets on UDP://127.0.0.1:25100

Loaded module GPSInput

Outputting depth on UDP://0.0.0.0:25102

Loaded module DepthOutput

no script telemetry/mavinit.scr

Log Directory: telemetry/logs/2020-07-02/flight2

Telemetry log: telemetry/logs/2020-07-02/flight2/flight.tlog

Waiting for heartbeat from /dev/autopilot

MAV> online system 1

MANUAL> Mode MANUAL

APM: ArduSub V4.0.1 (a8b440d6)

APM: ChibiOS: 0997003f

APM: Pixhawk1 0023002C 3137510D 33343537

no link

link 1 down

link 1 OK

heartbeat OK

Flight battery warning

Received 920 parameters

Saved 920 parameters to telemetry/logs/2020-07-02/flight2/mav.parm

Flight battery warning

Flight battery warning

LSM303D _read_data_transaction_accel: _reg7_expected unexpected

APM: EKF2 IMU1 forced reset

APM: EKF2 IMU1 initial yaw alignment complete

Flight battery warning

APM: EKF2 IMU1 tilt alignment complete

APM: EKF2 IMU0 forced reset

APM: EKF2 IMU0 initial yaw alignment complete

APM: EKF2 IMU0 tilt alignment complete
I’ll charge the battery now, but the output was the same.

Thanks
Dean

Hi, can you make sure that the assigned IP for your maching on this interface is 192.168.2.1?

Also, try manually setting the video options in QGC to “UDP H264” and por 5600 to check iff you are able to receive video.

Hi William,
By assigning the IP I assume you mean through System Preferences-Network? That’s set.

I’ve changed the settings in QGC as you suggested, and I’ve got live video now.

Still have the message that it’s waiting for vehicle connection.

Sorry for the delay in replies, I’m in Australia. Thanks for the help.

can you verify that the netmask is 255.255.255.0 ?

Hi William,
yep, screenshot attached:

@Dean.C,

Please, change your subnet from 255.255.0.0 to 255.255.255.0.

Please, change your subnet from 255.255. 0 .0 to 255.255. 255 .0.

This is incredibly embarassing. Yes, that was it. Thanks William and Patrick.

Apologies for the simple error.

Thanks all for the help
Dean

Hi @Dean.C,

As some people say, “The devil is in the details”. But we are glad that you figured it out !