Home        Store        Docs        Blog

Qgroundcontrol issue: the vehicle is not responding


(Lingxiao Wang) #1

Hello, guys:
When I try to upload the firmware (ArduSub-v2.px4; stable version; downloaded from the ardusub website) to the pixhawk, everything works fine. However, after the uploading completed, the qgroundcontrol told me that the vehicle is not responding (like the image shows). Anyone meets similar problem before? Or anyone knows how to solve it?

屏幕快照 2017-05-05 20.57.47
Thanks in advance!

Regards
Lingxiao Wang


(Lingxiao Wang) #2

BTW, my computer’s version is MacOS Sierra 10.12 & Qgroundcontrol’s version is V3.1.3


(Jacob) #3

Please try these steps in order:

  1. Close QGC
  2. Unplug the Pixhawk
  3. Plug the Pixhawk in, let it boot completely.
  4. Start QGC

Do you still have the same warning message after these steps?

-Jacob


(Lingxiao Wang) #4

Unfortunately, yes, the problem is still here. I tried this method like 10 times, and it did not work. I also tried to compile the source code, and upload it through the command: make px4-v2-upload. However, the result is the same: qgroundcontrol couldn’t recognize the Pixhawk.
One thing strange is the sound from the pixhawk after the uploading completed. Every time when I upload a firmware to the pixhawk, there are 3 long and loud “bee” sounds. These sounds pattern are new and never happened in my pervious experiments. I was succeed in the pervious tests (qgroundcontrol and pixhawk cooperates perfectly).
Any suggestions?
Thanks a lot!


(Lingxiao Wang) #5

I matched my pixhawk’s sound pattern with the sample on the Ethernet, and I found this sample is matched: http://download.ardupilot.org/downloads/wiki/pixhawk_sound_files/PX4_ReadyToUploadIOBoardFirmware.wav
The meaning of this sound is in this webpage: http://ardupilot.org/copter/docs/common-sounds-pixhawkpx4.html The fourth one: New IO board firmware found (restart with safety button pushed to upload).
How should I fixed this problem?
Thanks a lot!


(Rusty) #6

Hi Lingxiao,

Did you copy the compiled .hex files to the SD card that is in the Pixhawk? It is strange that you are seeing this sound message.

-Rusty


(Jacob) #7

Can you describe this in more detail? Were you flashing ardusub with success? Do you remember what you were doing when it first stopped working (maybe moving to a different version)?

I’ve never seen this before, I am looking for a solution.

-Jacob


(Jacob) #8

Try flashing another firmware to the board, like Copter or Plane. Do you still have the same issue after flashing one of those firmwares?


(Lingxiao Wang) #9

The other firmware (copter or plane) works fine in my pixhawk, but not for the ardusub.px4.
I uploaded the ardusub.px4 to my another pixhawk, and it works fine. I am not very sure why this happened.
Thanks for help!


(Jacob) #10

Can you please email the .px4 file that is giving you issues to support@bluerobotics.com? And can you take a picture of the pixhawk that has issues?


(Lingxiao Wang) #11

Sure. I think from the outer appearance of the Pixhawk can not know the inner configuration’s issue.
Here is the Pixhawk that has issues and the Ardusub.px4 file.
ArduSub-v2 (3).px4 (769.7 KB)


(Jacob) #12

I just wanted to see if you were using a genuine Pixhawk, which it looks like you are. The firmware you linked boots ok on my pixhawk. Based on the details you’ve provided, this is a really strange problem. Can you try loading ArduSub V3.5, and let me know if you have the same behavior? You will need QGC daily build to run v3.5.


(wuming) #13


(wuming) #14

Who can explain to me, what is the reason for this? I can not get joystick status?


(wuming) #15

Who can explain to me, what is the reason for this? I can not get joystick status?


(Jacob) #16

You can set up the joystick by clicking the icon that looks like gears, then clicking the tab that says ‘Joystick’.

  • Is your joystick plugged in?
  • Can you show what the joystick page looks like?
  • What kind of joystick are you using?

-Jacob