Home        Store        Docs        Blog

Having an issue with Firmware


(Todd Sparkes) #1

Hello,
I am having an issue with QGC. When I flash up the program I get a message that I need to update “frame_config”.
Please see attached screenshot. If anybody could assist I would greatly appreciate it.

Thanks


(Jacob) #2

Unless you have a particular need to use the latest software versions, please use the stable version of ArduSub and QGroundControl. I’ve just updated the documentation to recommend the stable QGC over the daily QGC.

-Jacob


(Todd Sparkes) #3

Thanks Jacob. I downloaded the recommended QGC file. What do I have to do with the ARDusub file?


(Jacob) #4

Are you using a BlueROV2? The ArduSub firmware needs to be flashed onto the Pixhawk. You can do that through QGC, click the icon that looks like gears. Did you flash a firmware file to your Pixhawk before? I noticed that the firmware version is showing up as 3.5-dev in your screenshot, so I assumed you flashed the firmware yourself, because we ship all of our units with 3.4.

-Jacob


(Todd Sparkes) #5

No I never flashed the pixhawk. I just plugged everything in according to the manual. When I starting going through the software setup I started getting the error notice. I will give it a shot anyway.
Thanks
Michael


(Todd Sparkes) #6

OK I am at the gears icon. What next?


(Jacob) #7

Click the ‘Firmware’ tab, follow the instructions for plugging/unplugging USB, click the ‘Advanced’ option, pick custom firmware file, and select the .px4 file you downloaded. This is the one you need if you are using the BlueROV2.


(Todd Sparkes) #8

Jacob when I click the Firmware tab all I see is this message - QGroundControl can upgrade the firmware on Pixhawk devices, SiK Radios and PX4 Flow Smart Cameras. There aren’t any instructions or advanced options.


(Jacob) #9

It should say ‘Plug in your device via USB to start firmware upgrade’, immediately below the line of text you quoted. Here is a video that goes through the process. You don’t have to do the steps in the last minute or so of the video after the firmware upgrade has completed.

-Jacob


(Todd Sparkes) #10

Good morning Jacob. Hope you had a good night. I just flashed the Pixhawk with the PX4 file.
Now I am getting a visual and audio error - No IO thread heart beat?


(undersearobotics.com) #11

“No IO heart beat” usually means that something is corrupted on the SD card. The fix is to pull out the SD card from the Pixhawk and reformat it with your computer. Here’s a thread where we helped Heinz with the same issue: https://www.bluerobotics.com/forums/topic/last-qgc-bug/


(Todd Sparkes) #12

Thanks Paul. Thank you Jacob.


(Jacob) #13

I’m glad you’ve got it straightened out. I’m sorry for the inconvenience, it was a mistake on our part.

-Jacob


(Alen) #14

Hello there, I’m having the exact same problem (same FW version, doesn’t recognize frame, doesn’t show the line to unplug/plug USB), so I didn’t want to open a new thread.

I’m curious which USB exactly am I supposed to plug out and then plug in to trigger the firmware update. Atm I’ve tried unplugging and plugging back each port of the fathom-x1 external unit. Don’t wanna mess with the other wires unless I have to.


(Jacob) #15

@Alen,
Please plug the Pixhawk into the computer directly over USB. You willl need to unplug the USB cable connecting the Pixhawk and the Raspberry Pi, then plug it back in when you are finished with the update. I have never seen QGC not display the text telling you to plug in the USB cable. Can you share with me what version of QGC you are using? It is shown in the top bar of the application window.

-Jacob


(Alen) #16

Thanks for the quick response :slight_smile:

It’s a work rov and I’m already home for the weekend, just thought I’d post here since I found someone with the same problem. I’ll try it when I get to work on monday and let you know.
Now that I launched QGC (using same laptop for work), it does say “Plug in your device via USB to start firmware upgrade.”, but whenever I started it if the rov was connected to the laptop at any point it wouldn’t show. The version is 3.1.2.

Thanks again, will update how it went on monday


(TCIII) #17

@Alen,
If the boot loader does not start at the start of the firmware update, then use a paperclip to reset the Pixhawk (the reset button hole is next to the USB port) and that should get the boot loader communicating with QGC.
Regards,
TCIII AVD


(Alen) #18

Ok, so I’ve managed to update the firmware.
Now I’m having a different issue, the joystick controls still aren’t doing what they’re supposed to. And I can’t seem to get to the frame options to see what the pixhawk thinks it’s controlling. Any help would be greatly appreciated


(Jacob) #19

Alen, please make sure you calibrate the joystick by moving the left-hand stick when the picture shows the right-hand stick moving, and the right-hand stick when the picture shows the left-hand stick moving. The direction that the sticks are moved should still be interpreted literally. After you have done that, please make sure your motor directions are configured correctly.

Which firmware did you download, and what vehicle are you using? If you are using a BlueROV2, you should download the ‘vectored’ firmware.

Note, there are no ‘frame options’ in ArduSub 3.4 (stable version).

-Jacob


(Alen) #20

Thanks for the help, much appreciated.
I am indeed using a BlueROV2, think I had the wrong firmware before.
I’ve got most of the stuff working now. Calibrated the joystick opposite sticks, now it’s working like this: left stick, when moved in any direction now activates both front motors and the rear starboard one. The right one does ascend and descend properly, and left and right activate same motors as the left stick. No matter what I try the rear port motor doesn’t spin.
I checked the connections and they’re all as they should be.