Home        Store        Learn        Blog

Tilt, lights and gripper not working

Hi,
I can’t get the lights, tilt servo or newton gripper to work. Worked fine earlier today, but now everything is dead. I got power and blinking blue status light on the pixhawk.
The thrusters are working fine, seems like all the aux outputs from the pixhawk got a problem.
What should i do??

Jørgen

Hi @Jhans, welcome to the forum :slight_smile:

It sounds like most of your Pixhawk is still working, and so it’s unlikely to be a power or cable issue. If nothing’s changed beyond the AUX pins suddenly no longer working properly as outputs then it’s possible the output driver of the FMU chip (which controls the AUX pins) has failed, in which case you unfortunately likely need to replace the Pixhawk.

I’d recommend you contact support@bluerobotics.com, link them to this thread, and outline when you got the Pixhawk (order number is helpful if you have it), and whether it’s been used in a standard BlueROV2 setup or something custom. They should hopefully be able to help sort out a replacement :slight_smile:

Ok, thanks. I measured the voltage on the molex connector going in to the tilt motor, and i got 5V. So seems that i got power to everything, just can’t control them…

Yeah, that sounds like the signals aren’t getting through, and my best guess for why is a chip failure.

If you want you can try having just one of the AUX peripherals connected at a time, to see if one of them is damaged and somehow stopping the others from working, and/or you can try connecting the AUX peripherals to MAIN positions (or use some other input, like a servo tester) to see if they’re all still working as expected.

If the devices themselves are fine off the AUX ports then that’s extra evidence that something in the Pixhawk has failed.

Ok so now i got the tilt unit working. I removed the yellow signal cable from the gripper and lights, then moved the tilt connector to aux channel 3 (where the gripper used to be) then the tilt worked. So i put the tilt connector back to port 1 as original, and now it works fine. But i still can’t get the gripper and lights working.
When i push the gripper connector into the top pin channel 2 or 3, i get a little movement in the gripper, just when i barerly touch the pin. But when i push it all the way in, i cannot control it.
Any options?

What are you calling the “top pin” here? The signal wires are supposed to plug in to the pins along the bottom of the Pixhawk, closest to the Raspberry Pi Companion Computer underneath, and furthest away from the labels on the top.