Home        Store        Docs        Blog

Gripper isn’t responding


(Cameron ) #1

Hi team!

I recently (within the past four weeks) outfitted my BlueROV2 drone with the Heavy Configuration Retrofit Kit and gripper. I’m having an issue with the gripper; it’s not responding to ArduSub input. I hooked the Lumen lights up to Aux 1, the camera servo to Aux 2, and the gripper arm to Aux 3. I’m using a Logitech GamePad F310.

• I’m running QGroundControl v3.2.4-BlueRobotics-Rev6.

• I have two of the buttons for the “servo_3_min_momentary” and “servo_3_max_momentary” functions to run the gripper, two buttons to run the lights, and two buttons for the “mount_tilt_down” and “mount_tilt_up” functions.

• ArduSub: The Pixhawk Firmware flavor installed is Stable 3.5.3

• Companion Software is up to date

• I checked the voltage across the terminals with a multimeter and there’s an appropriate amount of voltage across the terminals.

• I tried the lights on Channel 11 (Aux 3) and the channel worked

I have pictures available if you want to check it out yourself.

Any suggestions on troubleshooting?

Thanks,

Cameron


(Jacob) #2

To get it straight, the gripper is plugged into aux3, it doesn’t work. You unplug the gripper and put the lights on aux3, not changing anything else, and they work? Are you able to adjust the brightness of the lights (as if you were trying to open and close the gripper)?

If so, there’s a problem with the gripper hardware.


(Cameron ) #3

Yes! I unplugged the gripper from Aux 3 and plugged the lights, didn’t change anything else, set the lights channel to Aux 3, and I was able to adjust the brightness of the lights. So, there’s nothing wrong with Aux 3. Since it’s a problem with the gripper hardware, what should be done? I need a functioning gripper for the project I’m using the BlueROV2 for.


(Jacob) #4

Verify the input voltage at the gripper again, and contact support@bluerobotics.com to set up a replacement.