Home        Store        Learn        Blog

Struggling with Pixhawk GPS port

I know it was done before but after a lots of reading and trials, I just can’t make it work can someone help?

I have a Ublox F9P gps that I understand and know how to configure using U-center. I just want to send the plain GPS coordinate in te GPS port of the Pixhawk. In putty I confirm that the GPS send NMEA or any thing else require through it’s serial port. I then feed the Pixhawk GPS port with this signal.
I tried with NMEA and then with a bunch of other message including UBX. NO luck there.
I also tried to make everything in autodetect mode (from Qgroundcontrol → vehicule setup page). No luck either and Qgroundcontrol systematically freeze my GPS by playing with the setup. To a point that I fight with U-center rigth now to regain control of my GPS!
I think QGC is looking (waiting) for RTK fix. But I don’t want it nor use it for now. I have 3m accuracy and this is good enough for me right now.
I also don’t have a compass (or if there is one in my GPS, it is not configure). I read that heading of the compass and vehicule must match. That is not possible in my case.

I am using the following config:
QGC : 4.1.3
Rpi : 0.028
ArduSub 4.0.3
Pixhawk 2.4.8 (Pixhawk 1 I think).

Thank you

edit: I know GPS don’t work underwater but in a pseudo-boat config it will.

Hi @Charles,

I unfortunately haven’t used a GPS with the ROV before, so don’t have first-hand experience with setting it up.

This thread from 2017 covers several of the settings that should be set in QGC. If that doesn’t help I’ll see if I can pull in one of our team who’s got more experience with using a GPS in the ROV.

Not sure where you read that, but it’s not quite correct. Our GPS Positioning docs provide some more details.

You likely want to upgrade this to 4.1.4 (Releases · mavlink/qgroundcontrol · GitHub).

The numbers are definitely a bit confusing. From here it seems like 2.4.8 is indeed a version of the Pixhawk 1.

Follow up on this.
I make this work. The main problem was that I used the uart2 port of the Z9P gps to connect to pixhawk gps port but Ardupilot seems to automatically configure uart1. When I switched to port 1 the GPS was detected and I started to see the blue BR icon on QGC map. I tried to mimic the configuration on GPS uart2 but this did not work so I just stick with uart1 for now. I obtained 0.2m accuracy in RTK mode with rtmc correction injected in QGC on my base station laptop but the ROV GPS also connected to my test laptop show a 3D accuracy of 1.7 cm.

About RTK in QGC: The satellite seem to be limited to 20 during survey-in? Any way to increase this? My L1 L2 GPS see much more satellites (>30) in U-center (Ublox dedicated application). Also, does someone know why there is a difference between the accuracy shown in QGC (0.2m) and that measured in U-center (<2cm). It would be nice to include the 3D accuracy in the data information box widget in QGC. For now we can see lat, long, hdop, vdop and a couple of other but not the 3d accuracy.

About QGC icon: when the ROV show up on the screen, it was accompanied with an orange “L” circle. What is it? It did not show up every time and remain fix while the ROV move. It look like a base station point but it was not since I also see the base station (a pink QGC box).

Now I have to find a way to waterproof my GPS antenna and put it on a pole to do subsurface navigation in rtk mode.

Most of this is outside my experience, so I’ve asked about it internally and will get back when I’ve got a response.

It may be worth noting that our QGC documentation currently says that RTK GPS isn’t supported in ArduSub, but it’s possible that documentation is out of date. If it is out of date and actually is supported then you may be able to improve the shown accuracy by specifying a tighter accuracy in that setting.

Possibly worth putting it on/in something that floats, and just connecting it to the ROV via a cable? Depends how accurate you need the measurements to be.

Note that having a long pole protruding from the ROV will likely contribute a significant rotation force from drag, and even more so if it’s not placed over the vehicle’s center of mass. If you’re just using a cable and need it to be relatively taut then I suppose you could include a winch on the floatation device that winds cable up and down to match the ROV’s depth, although that increases complexity and cost, and requires estimating water density (or at least tracking measured depth vs winch rotation angle).

Hi Eliot,

thank you for your help. I will wait for your team reply but it is no hurry and I also understand that since it’s not supported in ardusub, it may take some time for them to find spare time for this. I’m fine with this! I plan to build QGC during winter season.

I will certainly follow your suggestion and put the pole on the center of mass. I made a fast removal pole setup so it will be possible to use the GPS only when needed and were drag will not be so strong. The antenna on the float is a good idea although it goes against the high precision idea behind RTK-GPS.

Has I try to do with all my post, I will certainly write a follow-up about this for everyone after my first couple of field trials.

have a nice day

Not sure what this is, although my guess would be it’s the “Launch” point or something, showing where the ROV was initially released from. If it’s of relevance the QGC Fly View docs have other orange circle indicators on them, seemingly corresponding to mission waypoints.

Fair enough, presumably that’s another reason in favour of using acoustic location underwater, since it can then be combined with the precision location of a floating normal GPS locator on the surface. If you’re only at very shallow depths then the GPS module on a pole approach will likely be fine though :slight_smile:

Sounds good, keen to see how this progresses :slight_smile:

You too!