Home        Store        Learn        Blog

External GPS issues-No position data in gauges

Hi all,

I am trying to use an external GPS (either connected directly to the Pixhawk, or via USB) to get surface position data (note, this is for a topside project, nothing underwater). I cant seem to get either method to work anymore (they used to), I’m using most recent ArduSub/companion and QGC. They appear to show position on the map, however there is no data reported to the gauges (lat/long etc) which is needed for video overlay. If I use the NMEA Router method, the same USB GPS works fine (so there is nothing wrong with the GPS).

Is this expected, or is there something wrong here?
I have tried numerous GPS units, baud rates, different com ports, GPS data rates, QGC GPS config settings, etc but can’t seem to solve the issue.

Thanks a lot

Hi!
Are you sending NMEA to companion port 27000?
https://discuss.bluerobotics.com/t/how-to-display-gps-on-ground-control/1442/8

Hi @spotxuv

Can you check what exactly are your versions of QGC and Ardusub? QGC 4.1 is out but there are still a few bugs.

I think the USB GPS option on QGC isn’t really available for the telemetry widget. It should work if connected to Pixhawk, though. How did you set it up with the Pixhawk?

@Boko no, I am trying to send GPS direct to Pixhawk via the on-board GPS plug. NMEA routing works fine though with the companion connected

@williangalvani I am using QGC 4.0.5, and Ardusub 4.0.2, I dont know if its a QGC issue as the Pixhawk is still flashing blue (no GPS signal), so I think there is an issue with hardware (Pixhawk or GPS) or with Ardusub not supporting this GPS method? Note, I have been trying this without the companion plugged in (Pixhawk connected directly to PC USB), could this be an issue? I have restored all the parameters to default as reading more of the documentation suggests QGC will configure any GPS automatically.
On the Pixhawk the GPS is connected to pin 1 (VCC), pin 3 (RX) and pin 6 (GND)

Thanks for any help

Hi @spotxuv ,

Ok, that makes things a little clearer. What data are you feeding the pixhawk exactly? Where does it come from?

Hi @williangalvani i have tried two different ublox GPS. They both work in ucenter. Initially I connected to the pixhawk VCC(pin 1), GPS RX/Pixhawk TX (pin2), GPS TX/Pixhawk RX(pin3) and GND (pin6), in case the Pixhawk had to configure the GPS, but it is now setup with pin2 disconnected. I have not manually configured the GPS as I couldn’t find any reference to doing that, which makes sense if the Pixhawk can do it.

I have left the system outdoors for up to an hour, and the GPS indicator LEDS show a signal, but there is no data showing in the widget(0 satellites).

Cheers

Hi,

I’ve recently being doing GPS tests myself. I advise you to use both rx and tx. As I understand, the gps port is able to setup the GPS once it is detected (change baudrate/protocol and ask the information it wants). Plug the GPS to the GPS port, and leave GPS_TYPE as AUTO.

Ok thanks, if you can confirm it works with ArduSub then it must be a hardware issue. I have 2x new GPS arriving today so will report back.
Thanks

hi @williangalvani , new GPS works as expected. Must of had two faulty units, thanks for your help!

1 Like

Maybe https://navio2.emlid.com/

This topic was automatically closed after 3 days. New replies are no longer allowed.