GPS connected to pixhawk in ArduSub

I believe I read that GPS is not supported in ArduSub, since GPS is not available under water. I would find it very use-full if GPS could be enabled. I would use it to document where I leave surface and where I re-surface.

Any help on this subject would be appreciated

GPS is supported with ArduSub.

I’ve had it working on a Pixhawk 1 with the old 3DR GPS module and on a Pixhawk 2.1 with the HERE GPS. I haven’t tried the ones from mRobotics yet.

Hi Kevin,


It works, just had to wait/move the GPS outside…

Now I just need to figure out how to show the position in QGroundcontrol…

Ok great! It should show up automatically, unless you are asking for the specific lat/long…that hasn’t been implemented in the widget yet.

My position is on the map, I was looking for the lat/long…

Working on adding it right now!

That is great :slight_smile:

Here you see the GPS

Ok great, let us know how it works in the water at the surface positioned like that. I’ve tried a few orientations and couldn’t get anything to work. I was going to see if one of these would be a better fit: mRo uGPS ublox SAM M8Q [Retired]

It works on the deck of the boat, but is not very stable in water…

Yeah, we’ll need to figure out some sort of mast to mount it on outside the ROV. GPS signals just don’t penetrate water very far.

After the latest software update, my GPS stopped working. The GPS is a BN-800 with a U-blox M8. Any idea what could have changed?

What is the GPS_TYPE parameter set to? It should be ok if it is set to Auto.

I tried Auto and U-blox, for GPS 1 in parameters

What messages do you see in the mavlink inspector? Can you show what it says for GPS_RAW_INT, and GLOBAL_POSITION_INT?

You have GPS_TYPE set to ‘None’. It needs to be ‘Auto’.

That was a mistake, but here you have mavlink inspector and GPS set to auto.

The GPS is connected to GPS - port on pixhawk

Unplug the battery from the ROV, then plug it back in. Then click the message box next to the battery voltage at the top of the screen in QGC.

Looks like this

What do the SERIAL parameters look like?