Home        Store        Learn        Blog

Ipad as Bluerov2 control

Hi! I am new to Bluerov2 and like to know if any of you are experienced users of MAC or ipad as ROV controller. I am planning to use either an ipad pro or an Macbook Air as control unit, but would like any feedback from you if there are any good or bad experience with this choice?

Hi @Roksund, welcome to the forum! :slight_smile:

QGroundControl, the ‘ground control’ software we use for controlling the ROV should work on Macs and iPads, provided the device meets the recommended specs. In saying that, we normally don’t recommend using tablets or phones for controlling ROVs because it’s generally difficult to make an ethernet connection with the tether, or USB connection if you’re using our FXTI (which comes with the ROV).

I personally use a MacBook Pro and a PS5 controller, but any Mac/iOS supported controller should work.

Macs tend to be pretty decent at decoding video, so the main considerations would be

  • SSD storage space if you’re planning to record a lot of video
  • screen brightness if you’re expecting to operate in bright sunlight without much shade/cover
  • battery life if you’re planning to operate for multiple hours without somewhere to charge
1 Like

Hi,

you can also try my iPad app for BlueROV.

Let me know if you need help with setting it up.

Grega

i’m testing your application with ipad pro, really nice, but i can’t find the command to tilt the camera. However, you did a wonderful job!

Hi! Thanks for your reply. I have downloaded your app and will try to use it as soon as my Bluerov is back from service. What hardware do I need to set up the app together with the bluerov2?

Do you use bluetooth controller?

You need Apple USB Ethernet Adaptor in combination with Apple Lightning to USB 3 Camera Adapter to make a wired connection between iPad and ROV.
When you start the application it automatically finds the ROV and establish a connection. It takes a moment to then starts video receiving. If app can not find it, disable WiFi on the iPad.
You can also use wireless game controller like Steelseries Nimbus to control your ROV.

I haven´t bought an wireless controller yet, but thanks for the tip. I will get to that soon.
Thanks for the update on the connections, are you using the Fanthom x-theter connector to hook up to the ipad from the Bluerov2?
As of today, my Bluerov2 has one HDMI and one LAN cable coming from the ROV.
I was thinking that the Fanthom x-tether box would be a good solution, in case I want to use a mackbook or an PC later on.
Have any thoughts on that?

Reg. Bjarte

Hi, HDMI cable that long?
Fathom-X tether works great.

Grega

:smiley: … well the hdmi cable is only a few feet, it is connected to the tether, same as the LAN cable. I have a hubrid system, with 220AC supply, and all cabeling is connected to a the teher through a box on the reel.
Thanks for your help so far. I will ask for your assistance again if I get into trouble :smiley:

No, only the ipad :-/

Ok!

Do you have an Android version of this app? I’m interested on trying to use a BR2 with my phone.

Grega; I have sent you an email regarding control commands. it seems like the control button functions does not show in the app, will this change when the rov is connected to the app?

Hi again!
I have bought an ipad connection as you described earlier, but it comes up with a message ÂŤconnection requires toi much powerÂť and ÂŤconnection not supportedÂť.I am using an Ipad pro.
Loooks like this app is not communicating with my equipment at all?

Reg Bjarte

Just put lightning power adapter on the usb adaptor.

Seems like this will not work :frowning:
I have tried different plugs and adapters now, but still no contact. The app does not find any connection to the Rov. The info I have is ÂŤdisconnectedÂť, see below.

any suggestions?

Best regards

Capt. Bjarte Røksund
Master Mariner/Maritime Pilot

this is my connection setup in the ipad:

Best regards

Capt. Bjarte Røksund
Master Mariner/Maritime Pilot

Oh… missed that….
You have to set the IP on the iPad to 192.168.2.1

Ok. I was thinking that the IP could be a problem. I’ll try that.

Thanks!

Reg
Bjarte Røksund