Integration of waterlinked GPS with U1 locator

Hi all,

We have bought the Bluerov2 and the underwater GPS G2 with the locator U1.

Right now, both of them can work well seperatly.

However, we are facing the problem of getting the GPS to display on QGC.

To specify, we did not buy the interartion git because we were told that with the U1 Locator,
the kit is not required.

So far, we have tried to connect the ROV(Ethernet) and the GPS(Wifi) through a bridged network with the IP of

We also added the Lon and Lat value on QGC settings to display the position of the Locator, but the value are 0.00 and never change.

To solve the problem, we found some useful instructions on the forum, and feel that we might have missed several steps regarding the setting of waterlinked companion page

or NMEA.

Here are some quesions related to the integration and we would like to figure it out,

  1. After the Wifi has been bridged, on which IP can we have the map of the GPS? (Before the connection, the default website is

  2. To achieve the integration, do we need to make any changes of the
    What we can see on the page is only a button of ‘Restart Waterlinked driver’.

  3. We have also read the documentation on the Ardusub that to use the GPS positioning system, we need to send NMEA data through at UDP port 27000. How can we make this setting? Can this be done directly from the panel of QGC?

We would also like to know if there are some other missing steps for the GPS integration.

Thanks for any help!

Hi @Neve, welcome to the forum :slight_smile:

I’d recommend you look at Water Linked’s documentation for integration without the kit.

I had a chat with one of our software engineers, and if I’m understanding correctly the connection should be automatic if you:

  1. connect the GPS G2 to your topside computer
  2. connect the ROV’s FXTI box to your computer (as normal)
  3. set up a network bridge between the GPS G2 and the FXTI

Perhaps @wlkh will have some additional insight on setting up the system if those steps don’t work as expected :slight_smile:

The companion computer can accept NMEA input on UDP port 27000 - QGC generally accepts it on port 14401, which shouldn’t be changed. Our Software Components diagram illustrates this :slight_smile:

Hi Eliot,

I have tried the steps you mentioned, unfortunately it did not work.

I have read the documentation from Ardusub that if the main LED on the pixhawk did not change from blue to green, then a valid position and lock is not detected by the autopilot :disappointed:. And the LED in our pixhawk keeps flashing in blue.

We have also turned to the companion page of the waterlinked driver, it did not show the sign of ‘Scanning for Water Linked underwater GPS’, (which was mentioned in the link of Waterlinked UW GPS Gen2 not autostarting Ardusub driver), every time I press the restart button, the website remain unchanged, so I am not sure whether the driver has been restart.

The link (Waterlinked UW GPS Gen2 not autostarting Ardusub driver) mentioned that the problem is only with the customer of G2, may I know if the problem has been solved now? Or is this the main reason that I could not get the GPS detected by the pixhawk?

Thank for your help!

Hi @Neve

To make sure the networking is working fine, please navigate to the web terminal in the ROV ( and type ping

If there’s no response, it means something is wrong with your networking setup and Companion is unable to reach the underwater GPS.

1 Like

Hi Willian,

I have tried your suggestion, the result is that the ’ Destination host unreachable’.

I have tried twice of resetting up the bridged network, it changed nothing.

Do you have any advice to fix this problem? Or is there any other reason that lead to the failure connection?

how is your bridged connection configured?
It should be configured with the IP and netmask

1 Like