How to toggle cameras in BlueOS?

Switched to the BlueOS system today which is working fine and have added a second USB camera. The system sees both cameras as when I power on the system I first see one camera and then after a few seconds it switches to the second camera. But I can’t see any way to toggle between which camera I see on the navigation screen.
I know the system can’t stream both cameras simultaneously but I understood it should be possible to toggle between 2 different cameras??
Any advice gratefully received.

You can access the stream settings by clicking on the cog at the top right of the video widget, where you should be able to change the selected video source. There’s a picture of this in the docs :slight_smile:

There are also some joystick button functions being added to switch between video sources, but I believe those are only in the development builds at the moment - they may not yet be available in a stable version.

Note that changing video source also stops the current video recording - it can be easy to get caught out by that if you’re not aware of it.

Note also that it’s possible to use other programs to receive additional streams, which may be worth looking into if you want to see (and/or record) multiple at once :slight_smile:

Thanks Eliot.

Seems like I have a USB connection issue here… I got the system to recognise both cameras on one occasion but now it seems that the RP is only recognising a camera on one of the USB ports (top right as you look at the 4 ports). I have two USB cameras and if I plug either of them into that port it displays their output in QGC but it doesn’t see either of them if they are plugged into the port below where previously I had the second camera plugged and visible when switched. Any thoughts or other tests I can do to try and get this working?


My main thoughts are:

  1. Are both the cameras appearing consistently on the Video page in the BlueOS web interface? If so you may be seeing the issue recently brought up here.
  2. If it’s a port issue it could be one of:
    • the cameras weren’t both plugged in to the same locations when BlueOS was first started, so they’re being detected but only one port is automatically being streamed
    • the Raspberry Pi is struggling to provide power to both cameras, either because
      • it has insufficient power itself → possibly try a power supply with a higher current capacity
      • it can’t provide enough to the USB ports → possibly try using an externally powered USB hub (may also be a valid solution to the previous option)
    • one or more of your RPi ports are damaged → may need to repair it or use a different RPi
  3. You could also potentially be facing signal issues from one or more overly long unshielded USB cables

Just checked and yes both cameras show up in BlueOS web interface

Just tried to do Reset Settings on the BlueOS interface and now it won’t connect at all even after restarting…?? Checked the Network settings which are correct but no web interface to the RP or connection with QGC…???

Problem solved. Refreshed the SD card and reinstalled. All working again now with both video streams visible at the moment… :slight_smile:

Glad to hear it! :slight_smile:

Hmm, interesting.

Do you know which BlueOS version you had flashed onto the SD card initially?

Our installation instructions specify that

so I’m curious whether you did a normal update from one of the 0.x beta releases to a 1.0 stable release instead of flashing, or whether this is an issue that was more recent.

Hi Eliot,

I just flashed the same version I had used originally which was the latest stable version as of 3 days ago.
It seems a little variable as I have had a couple of occasions where the BlueOS web interface shows two cameras with different names but when I go into QGC it shows two cameras to switch between but they’re actually the same camera! They show different names but its the same image displayed. shutting everything down and restarting seemed to clear it so far but I’ll keep an eye on it and try to identify if its any specific circumstances that causes this issue.

Ok, so probably not fully resolved then.

Thanks for the extra information - it will useful in tracking it will hopefully be useful in tracking down the issue :slight_smile:

I have two cameras. The second has been toggled by a small script for VLC-Player. The records for the second camera are recorded by the window’s gameplay records, parallel to the Qgroundcontrol records.

I can’t find the advanced settings in the camera settings as described.
Is there anything I need to do to have these options?
I have tried both version 4.17 and 4.22.

Is there anyone that have an easy explanation about how to set up and VLC script for an extra camera?
Was also thinking about setting that up as an extra screen.

Hi Eliot,
Can you confirm wether anyone has looked as this video issue further or wether anyone else is having the same issues. I’m still having the same problem. I have two USB cameras attached to the RP. The Blue OS sees both cameras but the QGC display mostly only shows me one or other of the cameras and doesn’t recognise theres a second camera available. This is not consistent. Sometimes I see one camera and other times I see the other camera. Very occasionally I get both cameras and the option to switch (although not often). Please see attached screenshots showing what BlueOS sees and what QGC shows me. Any thoughts on how to move this forward or do I need to look at 3rd party solutions to using two cameras with the system?

Hi @nemorov ,

We’re tracking this issue here. I expect it to be fixed soon.


Thanks William. Fingers crossed… :slight_smile: :crossed_fingers: