USB Camera setup

I am just setting up a navigator for experimenting with a teatherless configuration.
The Blue robotics standard usb camera guide shows a pretty much plug and play setup.
Currently BlueOS is not detecting any cameras despite the usb came plugged in. I assume the camera is been powered by the usb5v but there does look to be power connection traces on the circuit board. Does the blue robotics cam need external power as well. Thanks

Hi @andrewjamez -
The USB camera is indeed plug and play, and no additional power connection is required. If the Video Streams page is not detecting the camera, please plug the camera directly into your computer to verify it works with the default OS Camera application (you may have to select the camera if you already have a webcam on your computer.)

If it is not recognized, it could have been damaged by the mount, per this technical bulletin. Please reach out on our contact form if you need a replacement!

Hi Tony, I’ve tried connecting the cam to my laptop and desktop without success. The computer doesn’t even register a plugged in device and the tell tale impressions on the plastic cover are present (see pic attached).
I will forward this information to Phillip from X-craft and he can arrange a replacement.

Cheers, Andrew

1 Like

Hi Tony, we have a new camera in now. When I plug it in to a PC/laptop this one works fine just as a normal webcam. When I pug it in to the navigator, unter “Vehicle Setup” it is showing as detected but in video streams it says no streams detected. When I “create” a h.264 USB cam video stream the vehicle setup shows "No streams configured’. I was under the impression that the navigator would auto detect the camera once plugged in? Also should the camera stream show up in the “Video Stream” page ? and are we able to record vvideo from it onto the navigator SD card memory given we are experimenting with a unteathered submersable.
Regards, Andrew

Hi @andrewjamez -
In order to see the camera stream, you’ll need to add a camera stream on the BlueOS Video Streams page. This should be the H264 stream (video2), and once configured will look like this:

You can also send the stream as rtsp, but this requires configuration in QgroundControl to receive (but works a bit better in Cockpit, automatically!)

Unfortunately, BlueOS does not support recording to the SD card by default - recordings are captured on the controlling computer with QGround Control or the Cockpit extension. You should be able to record locally if you were to run a command to capture the video stream to SD card, with gstreamer, but this may not result in as high quality a stream as recording is significantly more taxing than streaming for the Raspberry Pi 4.

1 Like

Hi, I think that I’m going through a similar problem but unsolved yet, I’m trying the blueos ins a raspberry to understand if the camera speed will do the job for me, my setup is an raspberry pi 4 and an usb camera, already tried 2 different cameras, they work fine in my pc, the lsusb command ins the raspberry pi shows me the cameras, but in the blueos webpage it shows “no video-devices available”. Sometimes it shows the add stream configuration but I can’t configure anything.

Hi @TPessanha -
What cameras are you trying to use? Do they support H264 video stream, and the UVC camera driver? If they are showing up intermittently on the video streams page, you could have a bad connection to them?
You should be able to add stream, select resolution and frame-rate, and select UDP or RTSP video stream.

I’ve tried an C920 logitech and an ov9726 camera module.

I have an IP camera in my place that is H264, what’s the best solution to connect it with blue os?

Hi @TPessanha -
The Logitech is UVC compliant - if it is plugged in on BlueOS start up, it should be available to add a stream for. The ov9726 should also be compatible.

To add an IP camera stream, you’ll need the RTSP url for the camera - I typically determine what this is via OnVif Device manager.
On the video streams page, you’ll then use that URL with the “redirect source” option to setup the video stream to be directed to QGroundControl or Cockpit.
Let us know if you encounter issues!

This is what it shows me when it started up with the ov9726, I’m connecting with the blueos over the wifi router.

When I activate the pirate mode this is what shows. Is one of them?

Hi @TPessanha -
That’s correct, pirate mode does need to be active. One of those two should work - the one that has H264 rather than MJPG available in the stream configuration.