Disable automatic video display on QGroundControl

Hi guys!

I noticed that QGroundControl with BlueOS will automatically display the video streams and the name of the video on the settings. While this is great and all, the video changing function is not very reliable and having 3 cameras on our setup, most of the time only 1 or 2 show up and its inconsistent with which camera shows and which don’t. I been trying to figure out if there is a way to just disable the video function altogether and just have the video stream show on OBS which is more reliable and also allows multiple video streams. Could you help with this, maybe I am missing something.

Thanks!

Hi @DeepWaterExploration,

That’s unexpected, and is something we’ll look into and try to replicate and fix. I’ve raised an issue for it here.

I’ve just tried this out and it seems like QGC’s MAVLink camera management is sufficiently separate from the direct UDP port receiving option that the normal “Video Stream Disabled” source option doesn’t apply, and there doesn’t seem to be any other option to avoid accessing cameras presented via MAVLink if one is available.

This could be fixed by adding a “disable camera streaming” option in QGC’s camera widget, and/or by adding a “disable MAVLink” option in our camera manager. I can see other benefits to that in BlueOS, so I’ve raised an issue for it that can be followed for updates/progress :slight_smile:

You’re welcome to raise a “Disable MAVLink cameras option” issue or pull request in QGC if you want, but it may be rebuffed as unnecessarily complex UI given the vast majority of systems where a MAVLink camera is connected will be intending to use it.

In the interim, the best workaround I can think of is to create a second endpoint for one of the streams, and then set QGC to streaming that one, at which point OBS can receive the duplicate stream from a different port. Definitely not ideal, but at least potentially better than nothing :slight_smile:

Edit: an additional workaround would be to ensure OBS is opened and connected to relevant streams before QGC is opened, which avoids adding unnecessary redundancy but is still not intuitive or user-friendly.

Following up @DeepWaterExploration, does the issue persist if you flash a new BlueOS image onto your SD card? Someone else seemingly had the same issue, but it apparently went away for them after flashing.

Doesn’t seem to do much difference re-flashing the OS. It could be that we are using 3 cameras than 2.

Also, there is no way to just turn off the streams either in BlueOS. It will always automatically start even when manually deleted. I was trying to to find a workaround like use BlueOS for flight controls but use DWE controls for streaming. Unfortunately, this method only works when you manually delete all the streams in BlueOS but every time a restart occurs, BlueOS will just automatically start the stream.

Yeah, in that other post it seems like the issue is still around for them too, they just thought it was gone initially.

From the BlueOS Video docs:

It seems like it would be useful for the latest configured settings to be persistent (which I agree with for multiple reasons), so I’ve raised an issue for that.

I was thinking it may be possible to make the auto-configuration happen with no cameras connected and then plug them in afterwards, but that also wasn’t persistent - presumably it tries to auto-configure whenever there are no stored streams.

Hi there,

I know its been a while. Just wanted an update to see if there are any changes with this!

Thanks!

Hi @DeepWaterExploration,

The camera manager has undergone some stability and feature updates, including adding support for Raspberry Pi cameras and improving the QGC integration functionality, but as far as I’m aware there isn’t yet an option to have no cameras streaming (although other settings should be persistent, including removing all but one stream) and/or to disable the MAVLink broadcasting of video streams. Any other details will presumably be in the comments on those issues :slight_smile: