Our USB Camera is not showing up on QGC

When we connect to BlueOS the camera shows that it is connected but then when we look on QGC it does not show up.

Hi @cece, welcome to the forum :slight_smile:

Have you followed our software setup instructions? This may be a firewall, permissions, or network configuration issue that prevents QGC from communicating with the vehicle.

It’s also possible that your camera is detected by BlueOS but doesn’t currently have a video stream set up. In the Video page of the BlueOS web interface you should see your camera with the current stream settings and a greyed out “Add Stream” button.

We followed the software setup instructions for the Navigator flight controller and the video page of the BlueOS web interface shows the current stream settings and a greyed out “Add Stream” button but it still doesn’t show up on QGC

Ok, can you please provide some more information about your topside computer setup?

In particular it would be useful to know

  1. Your QGroundControl version
  2. Your operating system version (e.g. Windows 11, MacOS 13.1, Ubuntu 22.04, etc)
  3. Whether QGC is receiving telemetry information (just video not working), or if it’s receiving no information from the vehicle
    • if there’s no information being received then it’s very likely a network configuration or firewall issue
  1. 4.1.6 is the version our QGC is on
  2. We are using Ubuntu 20.04
  3. We are able to use our motors and get gyro from it but no video.

Our latest recommended version is 4.2.4 - can you try that? :slight_smile:

Someone has previously reported having a firewall they didn’t know about, which may be worth checking in case the video stream on UDP port 5600 is being blocked.

We updated QGC and switched from Ubuntu to Windows 10 cause we were having some issues with Ubuntu and are still not getting any kind of video. We added a stream on BlueOS and is still not getting video. Though we don’t know what to do with the stream endpoint. We have tried a couple of things that we saw on the forum and some things with VLC, but haven’t been able to get it to work.

Hmm, that’s no fun.

The stream endpoint should be set to udp:// (or the port could be a different number (like 5602) if there’s already a stream set up at 5600).

That’s supposed to be auto-filled, but I believe we only fixed that in a very recent beta version.

Alrighty then. If the above steps don’t help, can you please

  1. Confirm that the camera can at least output a stream when it’s connected directly to your (topside) computer
    • the built in Camera app on Windows should work, or File/Open Capture Device on VLC
    • if possible it would be good to specifically confirm that the H264-encoded stream works, but I’m not sure if apps with a graphical interface tend to let you select, and it’s a bit more fiddly to use a command-line program like gstreamer
  2. Confirm that QGroundControl has been allowed through the Windows Defender firewall
  3. Provide a Console Log from QGroundControl
    1. Turn on the CameraIOLog, CameraManagerLog and VideoAllLog options via the “Set Logging” button
    2. restart BlueOS, and confirm the video is configured to stream
    3. wait for a minute or two after QGroundControl is receiving the telemetry data (to make sure it logs any relevant video activity)
    4. use the “Save App Log” button to save a log