BlueOS Loosing video feed but still connected

Hiya Eliot,
I made the transfer to BlueOS this morning
-Checked vehicle was functioning fine prior to update - all good
-Upgrade all went well, installed 1.0.1
-Everything went smoothly, I was able to interface through the browser and see everything
-Qgroundcontrol 4.0.5 connected, but lost video feed only after about 20 seconds of runtime. Still had connection and control
-Checked browser, camera was still “connected” and showing all as good
-I did note in the system page that "mavlink camera (I think this was it, it was at the top of the list) said sleep instead of run
-Attempted downgrading to 1.0.0, same issue. Feed only lasted 20 seconds then greyed out. Reboot would give me feed again, but only for about 10-20 seconds.
-Upgraded again to 1.0.1, same issue
-Changed back to my old SD card with old companion, and had a stable feed

I could not access logs in the browser, I received a notification that the web path was wrong. I tried the file browser too and was hung up on a rotating logo.
I could not find any recommendations on the QGC version which is recommended for BlueOS, if different.

I am back to having a working (downgraded) unit - but keen to hear if I am the only one having this issue!

Hi @Marruger, thanks for the feedback :slight_smile:

Are you able to try QGC 4.1.7?
That’s our latest recommended version (for all systems) :slight_smile:

That’s a known issue - at the moment the Log Browser works for our upcoming flight controller (since it runs off of the onboard computer), but unfortunately doesn’t yet work for Pixhawks because we haven’t finalised the mechanism for getting the log files off them.

That’s unexpected - I’ve managed to replicate the issue (and raised it here) but it seems to be browser-dependent. Could you specify which browser and OS you’re using, so I can add them to the list of currently problematic configurations? :slight_smile:

In the meantime the underlying service seems to be working fine, so you can access it via Tools/Available Services in the sidebar (it just won’t have the page header).

By the way, are you ok if I make this into a public post? It doesn’t seem to include anything private, and others could potentially benefit from the information / discussion :slight_smile:

Yes of course!
Thanks very much - I will give it a run with 4.1.7 and see what happens :slight_smile:
RE browser - it hung up using Chrome

1 Like

Confirming this is solved with QGC 4.1.7! Could be worth a note (if not already) in the install docs to update this part of the chain!
Thanks again!

1 Like