Video Feed Not Displaying in Cockpit

We are super excited to utilize Cockpit on our 1000m BlueROV! I’m having trouble getting video to be displayed. It doesn’t seem like the defaults of under the “General Configuration” menu for Mavlink2Rest and WebRTC are able to connect and I get the message “failed to connect”. I do get some telemetry such as battery voltage/curent and depth. The ROV works perfectly with QGC… Any help would be appreciated!

Hey Stephen! Nice to hear from you!

Could you get a screenshot from your BlueOS video stream page (http://blueos.local/vehicle/video-manager)?

There is a lot on the page so hard to get everything, but here is a screenshot that includes the only preview that is displayed.

Cool. This screenshot is fine.

Can you now go to Cockpit, open the edit-menu, click on the configuration button (cog) for the Video Player widget and see if the stream is available there?

Here is the screenshot from that menu. There seems to be a issue.


I will take a look here and also check with the ones responsible for the video streams to see if they have an idea on what is happening.

In the meantime, can you check if changing the stream from UDP to RTSP helps with the problem?

And just to better understand the problem, how’s your setup right now? Direct ethernet connection? WiFi router? ZeroTier? And which BlueOS version are you running?

Wait Stephen, I think I know what the problem is :smile:

From the screenshot I can see that you’re running BlueOS 1.0.1. This version does not have breaking changes that were introduced at the begging of the year on the video stream pipeline.

Can you update BlueOS to the latest stable and check if it solves the problem?

I’m connected through Zerotier so that could add some complexity. Its connected via ethernet.

Changing to RTSP did not help.

I’m running BlueOS v.1.1.1

I am running v1.1.1 …

Oh, I was looking at the Boostrap version. My bad.
v1.1.1 is fine, so this is not the problem.

@hube268 the telemetry data (which can be seen on the widgets) is coming on a good update-rate or they are lagging/inconsistent? I’m taking a look at the code and maybe it’s a timeout issue (Cockpit was expecting an answer from the camera manager but it did not came in time).

telemetry does not lag. When I move/tilt the ROV the horizon moves immediately in cockpit. I’m not in the water so couldn’t tell you about depth.


I will send you a DM so we can schedule a call and I can take a better look at the problem.

1 Like

With a stable source of power, and when not testing beta versions, it’s always a good idea to update bootstrap! If not, sometimes power cycling the vehicle can cause BlueOS to revert to the older, bootstrap version…

We got it to work!

Following is a post-mortem:

We found out that everything was working when I connected from my laptop to Stephen’s zerotier, and them we also found out that everything worked when Stephen connected to the ROV from another laptop or from an incognito window on the original desktop.

We reset chrome settings on Stephen’s desktop and everything worked, so my guess is that there was some flag on chrome://flags that was blocking the connection. Stephen confirmed to have done some configuration there to get another application working. Unfortunately we don’t know exactly which flag was it, but problem something related to WebRTC.