Home        Store        Docs        Blog

Blue ROV2 Waiting for Video

(Jean Filion) #1

Interestingly, my BlueROV2 does not show video. Everything else works great. I had a poke around the tech support and tried the following:

  1. Checked physical wiring. Perfect. Disconnected and reconnected it just to be sure.
  2. Added UDP Port 5600 open rule in Windows Firewall
  3. Disabled all firewalls in Windows 10.
  4. Checked to make sure in QGC Video Settings are UDP Video Stream port 5600.
  5. Ran the terminal commands and here are the outputs.

Any help would be greatly appreciated:

0 Likes

(Patrick José Pereira) #2

Hi Jean,

Try to restart you camera settings and reboot you vehicle.
You can access camera settings with this link: (http://192.168.2.2:2770/camera)

This will force companion to reset the video settings and configuration to its default value.

0 Likes

(Jean Filion) #3

I just performed the tasks you recommended.

! h264parse
! queue
! rtph264pay config-interval=10 pt=96
! udpsink host=192.168.2.1 port=5600

Still no video. It says Waiting for Video…

0 Likes

(Jacob) #4

Please contact support@bluerobotics.com to arrange some technical support.

0 Likes

(Marcus) #5

Are you running the BR version of QGC? Banner should read “v3.2.4-BlueRobotics-Rev6” or similar, you won’t get video using other versions of QGC (though you can get telemetry)

0 Likes

(Jean Filion) #6

Yes Sir, I am using BR Rev6.

I have new information for you.

I plugged the ROV into a second computer and the nav cam worked.

Both computers were purchased at the same time, are running Rev6, and are theoretically identical. Must be a driver issue ?

Any ideas?

Here’s a pic. The same ROV works on the laptop on the left, and the nav cam fails when I plug it into the laptop on the right.

0 Likes

(Michael Woodman) #7

Check you fire wall settings to see if that’s causing your problems

0 Likes

(Jean Filion) #8

Firewall disabled on both laptops. Here are the Diagnostics:

Works:

Fails:

0 Likes

(Jacob) #9

Hello @jfilion, please try the troubleshooting steps here, and take notes of your results. If you continue to have problems, please share the notes of your results with me.

It sounds like you might have the network interface set up incorrectly on the problem computer, or video disabled in QGC settings. Make sure the ip/subnet mask are exactly 192.168.2.1 and 255.255.255.0

0 Likes

(Jean Filion) #10

Problem SOLVED.

I had set my IP address to 192.168.2.20. It only works if my IP address is 192.168.2.1.

All fixed. THANK YOU !

0 Likes