Home        Store        Learn        Blog

No camera feedback in QGC

Hello, I am re installing the Bluerov2 on a new computer (I5 11th generation, GEFORCE 1050, 16gb RAM) latest version of QGC downloaded on Bluerobotic. I don’t have a picture on the screen but the controls are working. the camera has been tested live USB, it works, the read test with VLC on http://192.168.2.2:2270/vlc.sdp gives nothing, I have no picture. On win 10, the firewall is cut, the ports are open and unrestricted after checking in the resource monitor. I do not know what to do. Excuse my English, I’m French :wink:

Hi @Bruno1, welcome to the forum :slight_smile:

I’d suggest you check our “No Video” troubleshooting steps, and report back with the results if they’re not helpful.

Hi @EliotBR . I followed all the points on the page starting with UDP H264 video stream - 5600. what is weird is that it worked before on my old PC but not anymore. i tried on 3 different computers 2 with win10 and 1 on mac os. i tried the live camera with a usb extender it works. On 192.168.2.2:2270//camera, it is active and well detected.

If on windows 10 try disabling your Ge-force graphics card, then check your screen font is 100% not 125%, also check you downloaded the most recent “stable” version of QGC, it may even be worth rolling back a few versions to see if things change for you

thank you, this has all been done. tested on an old version 4.0.6 of QGC. still no picture. launched in “command prompt” no log error.
how to run QGC in safe mode?

Hi,
Can you double-check your network settings?
Especially that the subnet mask is 255.255.255.0?

yes
(TCP/IPv4)
IP 192.168.2.1
subnet mask 255.255.255.0
All communication are good, motors, tilt camera, light, trigger … but no vidéo…
caméra is active status

can you to go the terminal page and type “screen -r video” to check if there are any errors there?

on windows 10 ??

please guide me to do it under windows 10



Hi, just open http://192.168.2.2:8088/ and it should show a terminal in your browser =]

thanks

erroneous pipeline: no delement "v42lsrc" is probably the issue at hand.

This is very odd. It looks like gstreamer-plugins-good is missing.

How did you install your companion? Is there anything unusual about it? Are you running on a Raspberry Pi 3 B ?

try opening a web terminal window and running sudo apt-get install gstreamer1.0-plugins-good, then reboot.

this is the original configuration, I did a dive with the bluerov2 two weeks ago with another computer and everything was normal.

i try it

sudo apt-get don’t work on terminal windows

We need more information, what error was displayed?
I suspect your sd card got corrupted somehow, I’d just re-flash it.

no error on QGC, just missing video.
after sudo apt



gstreamer