No connection to QGC on Ubuntu 20.04

Hi everyone,

Does anybody have any suggestions for solving the following situation:

  • laptop with Ubuntu 20.04 and QGroundControl 4.1.6
  • Companion Software 0.30 and ArduSub 4.0.3
  • network connection has been set up with IP and netmask (verified by ip address show)
  • we can ping the pi on
  • we can ssh into the pi and ping ourselves back on
  • all services (video, mavproxy, etc.) are running according to the system page and both the camera and the pixhawk are shown as detected devices
  • using screen -r on the video and mavproxy processes is not showing any obvious errors
  • mavproxy options are the default options
  • all options in QGroundControl are as they came (auto-connecting to UDP, video port 5600)

But QGroundControl is not connecting. We don’t see a video and it says “disconnected” at the top. Did we miss a step somewhere?

We have successfully connected this ROV to another (Windows) laptop before but will need to use the Ubuntu laptop on this occasion.


Edit: Our IT team, who set up the laptop, set up a firewall without telling us. sudo ufw disable solved the problem. *facepalm

So, after finding out about the firewall issue: which ports do I need to enable for QGroundControl? Is there a list somewhere?
5600 for the video and 9000 for the control?

Check out the Software Components docs :slight_smile:

QGC requires port 14550 for MAVLink (control), 5600 for video, 5601 for audio, and 14401 if you’re forwarding NMEA messages to it.

If you’re using a Ping Sonar or Ping360 you may also need to allow ports 9090 and 9092 respectively for Ping Viewer to connect correctly.