Home        Store        Docs        Blog

Can’t switch to GPS “flight" modes

(Jesper) #1

I really hope you guys can help us with this, we have searched everywhere but can’t seem to find an answer for this. So we are planning to use Ardusub on or boat (not a sub), and the reason we are thing of using Ardusub instead of Ardurover/Arduboat is that are no support for use virtual joystick in qgroundcontrol. That way we don’t need an RC, but only a SIK radio. The boat will be in Auto mode 99% of the time.

But we can’t switch to any flight mode that use GPS. In qgroundcontrol for Windows we can see this modes but don’t switch to any of them. In qgroundcontrol for Android these modes doesn’t even show up. And we have 3d lock and all pre-flight check are ok. And because this is a regular boat we use a regular GPS (neo 8). Are there any parameter or so u have to change to use GPS mode in Ardusub, or anything else that need to be done to use GPS? Or what are we doing wrong, hope u guys have an answer for us, I would really appreciate it. I can mention that when we tried Ardurover there no problem switching to GPS flight modes, so there seems that the hardware are okay.


(Kevin) #2

Hi @Jeos72,

There are no extra parameters for the GPS to work, you should be able to plug in your GPS into the right port and get positioning info.

Because this is a scratch build, what hardware do you have?

Do you have a stable telemetry connection through your SiK radio?

What version of QGC do you have?

If your drop-down isn’t working, try assigning the flightmodes to buttons on your gamepad.

Also, note that ArduSub doesn’t work so great with surface vehicles in AUTO at the moment. Manual control, stabilize, and position hold wok fine, but AUTO has issues.

(Jesper) #3

Hi Kevin,

Thank you for your answer, yes I was not clear on that point, we get GPS
information with right position. But we can’t change mode to any of the GPS
modes, Auto or Position hold. We use Pixhawk 2.8.4 rev3 and a NEO 8 GPS.
And we have tested the hardware with Ardurover, and then everything works
just fine. No problem switch to auto mission, but with Ardusub we can’t
switch to auto mission…It’s really strange. I don’t have QGC on this
computer so I don’t know what version we tried whit, but it should be the
most resent one. But if auto doesn’t work well with a regular boat then I
don’t know if this is a good idea with Ardusub, but as Ardusover don’t
support virtual joystick we can’t use that. And that function would suit us
perfect just to get in to sure and out…



(Kevin) #4

@Jeos72 Thanks for the further information, I have a few suggestions on things you can try to resolve this.

  1. Conduct a full wipe of your Pixhawk to remove and left-over parameters if you updated the firmware from say ArduSub 3.5.0 to 3.5.2. To do this, load a version of ArduPilot (Rover, Copter, Plane) that isn’t ArduSub. Then go back and load the most recent stable version of ArduSub. I’ve had to do this once or twice when things were acting weird for me. A full wipe usually fixed my issues.

  2. Try both versions of QgroundControl. The recommended from Blue Robotics can be found here: https://github.com/bluerobotics/qgroundcontrol/releases. The daily download of the standard QGC can be found here: https://docs.qgroundcontrol.com/en/releases/daily_builds.html I recommend trying them both before moving into hardware corrections.

  3. Your SiK radio, for whatever reason, may be the issue here. I remember some previous community members who had issues with ArduSub and their radios. For my USVs, I haven’t used a SiK radio, but I’ve switched over to Wi-Fi (and later 4G and Iridium).

For Wi-Fi, you have two paths:
a. You can try following the wireless topside instructions from Blue Robotics: https://www.ardusub.com/miscellaneous/wireless-topside.html
b. You can follow the instructions from ArduPilot for their APSync: http://ardupilot.org/dev/docs/apsync-intro.html

I’ve had both methods working. APSync is easier to setup and uses less hardware, but has shorter range. The BR wireless topside will give you a camera option with a bit of lag.

At this time, I wouldn’t recommend using ArduSub for a boat because of the weird auto functions on the surface. It needs further testing. From the tests I ran back in December 2017, auto will engage and the vehicle will rotate to the heading of the next waypoint, move around 10m and then stop. I’m not sure why it does that, but that has been my results.

If you’re going to be in auto 99% of the time, I’d recommend ArduRover for right now.

(Evan) #5

Hi Jasper

I am running Ardusub over Sik radio using Xbox style controller, I can confirm that stablized and position hold work fine , but auto does not work well.
There does seem to be some lag in the system when switching between modes. Having a only quick go on the virtual joysticks they seemed to produce more lag than the usb Xbox controller.

Being a 3D waypoint system there maybe problems with z height fluctuations, causing the boat to stall waiting to achieve a specific z value.

I posted a similar question regarding Rcin as I wanted to use a rc transmitter with ardusub. Have a look at that post, there seems to be a few request for boat specific features recently. Would be good if the offer different frame configurations in ardurover/ardruboat in the future.

(Jacob) #6

There is support for ‘Manual Control’ messages in the latest ardurover and QGC. I’m not sure if either has made it to stable yet, but it’s there.

The auto modes require a 3d lock with 6 or more satellites. If you still can’t arm then please confirm the version of ArduSub and QGC.

(Jesper) #7

Thank you guys so much for all your help, that has help us a lot. As I understand from all of you is that auto mode doesn’t work very well on regular boats, and that’s the mode we are going to use almost all the time. This means we can’t use Ardusub for our purpose.

We are going to user the boats for sonar mapping (depths) lakes in Sweden where you can’t take a normal size boat. And therefore this boat is going to be in auto mode on mission/survey almost all the time like I said before.

And is it like you say jwalser, that joystick mode is support in Ardurover we will certainly take a look at that.