Building Ardusub For Navigator

Recently i have been messing around with some of the settings in the custom frame and joystick files in ardusub to change a few things, however, I’m having some notable problems when I try to compile for the navigator board. I seem to be able to get it to work for the Pixhawk, where QGC will see it and allow me to use the ROV, but when I try to upload my custom Ardusub file that I have complied for the navigator, it will upload, but never connect to QGC and I’m not entirely sure what’s going wrong.

I have currently i’m following along with The Ardusub Compiling Guide and have tried:
Using the most recent stable version of ardusub
Using the 4.1 variant of ardusub
I get no errors when i make the file and I have tried not changing anything before uploading it but it still won’t work and i get no errors that i can find as to why QGC won’t see it.
Is there something obvious i could be doing wrong that leads to this?

Make sure you are using gcc 9 or 10. newer ones are not compatible with glibc in the Pi.

I have some WIP instructions here for 10.2 here.