Home        Store        Learn        Blog

BlueROV2 integration with GPS v2 with locator A1

Good day all,

I am communicating waterlinked GPSv.2 having locator A1 with BlueROV but the locator and depth readings are not showing up on waterlinked webpage neither on QGround.

Please help me in wiring of the locator and control signals from BlueROV and GPS module.

Thanks in advance

Hi @zeshankhan43210,

Have you tried following the Water Linked documentation? They include BlueROV2 integration instructions which should hopefully help solve your interfacing issues :slight_smile:

If you’ve already followed those steps and it’s still not working, which versions of Companion, ArduSub, and QGroundControl are you using?

The Wifi of the companion computer will remain in scanning mode and there’s no internet connection. I can’t get the software version of ArduSub.

Following are the software versions;

Companion Software: 0.0.15
QGround: 4.0.5

Regards,

The Water Linked instructions specify you need at least Companion 0.0.22 for their GPS to connect, so you’ll need to update the Companion software.

Given this, I’d recommend you try the direct flashing method of installing new Companion software. That unfortunately requires opening the enclosure to access the Raspberry Pi’s SD card, but if your wifi/internet access isn’t working then you don’t really have other options. There are some steps in this comment for opening the enclosure, if you haven’t had to recently.

While it’s open, you can either connect the Pixhawk to your topside computer and flash on a new ArduSub, or once your Companion has the latest software you can connect it to wifi and update ArduSub on the Pixhawk via the Companion web interface :slight_smile:

Thanks Eliot for your support. While I am doing the software update will you please send me the wiring diagram from BlueROV to the GPS2 board as I do not have a connection box and have to connect the wirings directly.

Regards,

Regards,

The best indicator of the wiring is in the docs I linked you to:

The blue/white pair of wires that goes into the Fathom-X is expected to also be connected to the blue/white pair from the Water Linked cable connector. The green/white tether pair should be attached to the A1 locator in the ROV, and at the surface end should connect to the brown/white wires from the Water Linked cable connector. Without access to the Water Linked system I can only assume they follow the “Tether” connections from our connector standard, which you should be able to use to determine which wire goes where :slight_smile:

Thanks alot for your response.

We have done the connections as per the given wiring diagram but are still unable to get GPS locator and depth value on Waterlinked’s Web GUI.

  1. Can you please guide on which pins of locator bulkhead connector (of GPS kit box) do we need to connect the ROV and locator wires? Right now we have connected ROV control wires to Pin 1,2 and Locator wires to Pin 7,8 of bulkhead connector.

  2. Is the Fathom X board required to be connected inside the GPS kit box somewhere, if yes where?

  3. BlueROV2 Integration document says that we need to desolder/ remove R2 and R3 resistors in case we are using A1 locator, is it so?

  4. Moreover, one thing we have noticed that the lights on Ethernet connector of Master Electronics Board do not blink when connected to the Interface Electronics Board.

Hi!
I can confirm that you have to use a Fathom X board in the Waterlinked box to be able to get network by one twisted pair (tether). To check function you should have network LEDs on waterlinked box signaling connection.

If you do not like that setup (like me) you can also do a standard network with a network switch instead.
That means going into Waterlinked box with an extra network cable or penetrator.
To test network you could try to ping Waterlinked from ROV computer, usually on 192.168.2.94

Link to WL manual when diving deep into there website: Hardware - Documentation
Regarding cutting resistors: “This step is only necessary for Underwater GPS G2 bought before June 2021. For units produced after June 2021, this step is not necessary.”
BlueROV2 integration - Documentation

Can you please guide me through wiring diagram.
Right now we have 2 boards in GPS v2, one is locator + receiver board with PLC module and other works as main GPS board. We have an Ethernet cable connected between both boards.

The pairs of ROV control and locator cables are connected at the bulkhead pin 1,2 and pin 7,8 respectively.

Is this the right configuration? How we can connect fathomX in between the board.

Please guide me through wiring diagram.

Hi!
Odd with GPS connected to Waterlinked by ethernet, its usually integrated on board, is that your own build?
Either way, if you already have used all ethernet ports in Waterlinked box, and do not want to change that, you have to add a network switch.
Adding information: Fathom X is only changing media from one pair network to standard ethernet.
That means fathom X also needs an separate ethernet port.
If you need more Waterlinked support on odd hardware I suggest you ask this on Waterlinked support, bottom of this page: Underwater GPS - Waterlinked Customer Support

Dear Bo,

By GPS I mean to say waterlinked GPS module, it has two boards once placed at side and other in middle of pelicase.

In older version of waterlinked GPS there is only one board and one fathomX connected with each other through Ethernet. But in new we waterlinked GPS module v2 Ethernet link is connected between side module and main module.


Please check the difference

Hi!
I have not seen the BR integration kit.
The connector on the board with outside connectors is just for reaching the FXTI interface, it is not an ethernet function, meaning you should not connect an ethernet cable here.
Connect a short ethernet cable from Fathom X ethernetport to Waterlinked ethernetport.
Then, the two connectors on the Fathom X in the Waterlinkedbox should be connected to the same connectors in the FXTI box from BR. You can verify that just by beeping the two leads.
Apart from that, the two other leads for transmitter goes the same way to FXTI box, but here only connected via tether to ROV side transponder.

Dear Bo,

Thanks for your quick and positive responses.

How we can enter the “the two connectors on the Fathom X in the Waterlinked box” in the pelicase as there are 4 receiver binder and 1 locator binder connections only.

One suggestion from waterlinked representative is to connect transponder wires at pin 1,2 and FXTI (blue ROV control cables) at pin 7,8 but there is dead end at the side board which means that I can not connect the wires to fathomX of waterlinked box.

Note: I am using Waterlinked GPS V2

Hi!
You might have to solder to the contacts.
This on the pair going to tehther function .
Try measuring from FXTI box to see where this pair is ending when connected the locator cable going to FXTI