Lights not working, triggers only when moving forward

My ROV just got an additional 2 lights attached to it. I noticed in a test drive yesterday that when we propelled my ROV forward the lights would flash on. I went to fix this today and noticed that the controls /button sets have not been changed. When I changed the Lumen light channel my camera tilt started to function. I now have no lights and the inputs for the lights change the camera tilt. I’ve tried changing the camera tilt buttons and the light buttons. If I change either I lose the camera tilt completely. Below are screenshots of all the button set ups.
I’m still not sure why the lights went on when the forward thrusters were triggered. Thanks for the help!

light channel
Camera Channel

Hi @ellieechoes,

That’s definitely not normal, and would suggest you’ve got some incorrectly plugged in or set up connections, or possibly some kind of short circuit or strong noise messing with your PWM signals.

How are your lights and camera plugged in to the Pixhawk? In a normal BlueROV2 setup I believe they’re in output channels 7 and 8 respectively. If you’re using a BlueROV2 Heavy, or if you’ve got two sets of lights with independent control of each then you’ll need to make sure the output ports are set up correctly for that. Note that the MAIN output ports correspond to output channels 1-8, and the AUX ones are for 9+ (e.g. AUX 1 is output channel 9).

See if you can set the output ports to how your devices are plugged in, and if that’s not successful it’d be great if you could share a picture of your Pixhawk ports labelled with where the lights and camera are plugged in :slight_smile:

I did not build the ROV unfortunately, the engineering shop at my university did. I emailed them asking about how they installed the lights and this is what they said, “The sensor wire (yellow in color I believe) was spliced to the other yellow sensor cable from the 2 existing lights. This was done because the connector in which the light sensor wire connects to has 1 input. The red and black power cables were connected to its respective bus block.”

I am not using a heavy set up. I did want all 4 lights with just 1 control button. I will try and get pictures of the pixhawk. I don’t know which are plugged into which hopefully the above description helps with that. Taking out it’s pixhawk is a little difficult for me since I don’t really understand how to pull it out as one comprehensive unit. I am willing to learn though. So I’m not sure if the pictures are helpful.

That looks like a normal setup (lights MAIN 7, camera MAIN 8), although by the looks of your images the lights connector (with the single yellow wire) is partially unplugged (it should be pushed in so it’s in line with the other black connectors beside it).

Taking the relevant info/steps from our assembly guide (but in reverse), to access the electronics you can:

  1. Ensure the ROV is powered down
  2. Unscrew and remove the vent plug at the back of the electronics enclosure (put it somewhere safe)
  3. Remove the electronics enclosure front attachment screws (put them with the vent plug)
  4. Remove the electronics enclosure acrylic parts

Removing the Electronics Enclosure Endcap:

Remove the Watertight Enclosure for ROV/AUV with Dome End Cap installed from the rear O-Ring Flange (4″ Series). If this step is difficult, you can place a large flat head screwdriver into the slots on the O-Ring Flange (4″ Series), and then twist to get a gap between the acrylic tube and the O-Ring Flange (4″ Series). Once you have the gap, you can wedge a screw driver between the end of the acrylic tube and the O-Ring Flange (4″ Series) to finish removing the acrylic tube.

  1. The electronics are now accessible, so you can push the lumen wire back into its position in MAIN 7 (it may be a bit of a tight fit)

I’d recommend you test the light and camera functionality before reassembling the enclosure. It’s fine to power up with the enclosure off, just keep your hands away from the electronics while they’re turned on.

Hopefully all this requires is plugging that cable back in, but if there’s anything else awry/still not working then if you want you can loosely slide the acrylic parts back on (you don’t need to push it fully back over the o-rings, just enough to protect the electronics from dust and people), and post any follow-up questions. Otherwise feel free to reassemble by just following those steps in reverse :slight_smile:

Thank you very much! That seemed to fix everything! I didn’t even see that the wire wasn’t even plugged in all the way until you pointed it out. Also thank you for your detailed instructions, I was very nervous taking out the brains from the ROV. It was super helpful to know that I was doing the right steps! Thanks again!

1 Like

Great to hear!

Fair enough, helps to know what to look for - thanks for the photos! I’ve had similar issues on a different system in the past, and depending on how the enclosure was assembled it’s possible for things like that to occur, especially on custom cables that might be a bit short or tight :slight_smile:

Not a problem, glad I was able to help. Everyone has to start somewhere, and having detailed instructions when starting out can definitely help build confidence to explore things further down the track :slight_smile:
Also helped that I could cannibalise our existing assembly instructions and photos - made it much quicker and clearer than if I’d had to set those up myself :slight_smile: