Home        Store        Learn        Blog

Lights not being controlled

New build and lights are not changing. Will come on when powering up and stay on. If disable them they will stay off until i enable them. Verified the buttons 13 and 14 on controller are functioning.
Any suggestions??

Hi @wjwalker,

My guess is that the port your Lumen lights are plugged into isn’t configured as a lights control port. In the QGroundControl Lights Setup Page you can see which ports ArduSub thinks are being used for lights. As a couple of examples, if your lights are plugged into the MAIN 7 output of the Pixhawk then Lights 1 should be configured as output Channel 7, whereas if your lights are plugged into say AUX 2 then Lights 1 should be set to Channel 10 (8 MAIN + 2 AUX).

It may also be worth double-checking your Joystick Button Assignment to ensure that buttons 13 and 14 are actually corresponding to the desired functions of lights1_dimmer and lights1_brighter :slight_smile:

Hey Eliot,

Here is a picture for the lights plugged in.

The lights 1 I have been switching to disable to have lights go out. Otherwise it is set to chan 7 and brightness steps 8.

Is there another channel I could try??

Another question- How is the BR2 coming up with the speed through the water ?? Do I have a GPS module that I didn’t realize??

Thanks for the help. Had a good time practicing driving it around in pool. The firmware update and auto detect for motors worked great.

Bill

Hey Bill,

That looks fine :slight_smile:

It’s understandably not supposed to “function” like that. Our support team mentioned a few hours ago that there have been a small set of similar cases that have been related to what might be a previously unknown failure mode of the Pixhawk. Given your setup looks fine I’d recommend you send an email to support@bluerobotics.com so you can discuss if it’s the same issue, in which case they can either send you a replacement Pixhawk or set of lights depending on which one’s actually faulty :slight_smile:

Yep, they can at least go in the first three AUX ports, you just need to make sure the yellow wire is at the bottom (not the top), and set the Channel appropriately (8 MAIN + x AUX) on the lights page. My above recommendation still applies, but it wouldn’t hurt to see if using a different port fixes the issue :slight_smile:

Haha, we wish. The flight controller (Pixhawk) has an Inertial Measurement Unit (IMU) which measures acceleration in and rotation about all three motion axes (which is used in the Stabilize and Depth Hold flight modes). Acceleration measurements can be integrated to give a velocity estimate.

Unfortunately acceleration data isn’t amazing for estimating position. While it’s possible to integrate twice to get a position value, the resulting estimate drifts quite significantly over time, especially at turns, so isn’t suitable for navigation purposes.

Normal GPS doesn’t work underwater, but there are alternatives available. If you’re interested in underwater positioning I’d suggest you take a look at this thread, and possibly branch out into some of the topics that are linked just below the initial post :slight_smile:

I added a positioning tag yesterday, so there will also be some interesting posts there, but I most likely have missed several of the older useful ones.

No worries, great to hear! :slight_smile:

Eliot,
Plugged lights in to Aux 2, changed control to Chan 10, and still have same problem.

Lights are not steady and have some flicker.

Bill

Update.

Plugged lights into Aux port 2, changed control to chan 10, and still same problem.

image001.png

Same problem. New BROV arrived and assembled. Lights flickering when dimmed, when controlled to full brightness the lights are 100% on and steady. When dimmed down the lights starts flickering.

Tested:

  • Light set tested on thruster Commander - All OK
  • Lights tested on several Pixhawk channels - Same problem on all channels
  • Replaced Lumen Light set with a brand new pair of lights - Same Problem
  • Verified correct button assignment.
  • Updated to Companion 0.0.30 same problem
  • Ardusub 4.0.3 (will not update might be the case)

Will try to get around the Ardusub update issue but in the meantime any ideas is welcome. This is 10th BlueROV we are putting together but this issue was new…

Replaced the Pixhawk - problem solved…

1 Like

Were you trying to update before or after updating Companion? The Companion 0.0.30 release was made to fix an issue that meant ArduSub firmwares weren’t able to be downloaded. That said, 4.0.3 is still the latest stable, so shouldn’t need to be updated from at this stage.

Yep, it was a new issue for us as well - it seems like a small number of Pixhawks had faulty overcurrent protection on the output lines. We’re now actively checking for that on our outgoing products, but the issue was only realised last week after a few people with new ROVs brought it up.

As above, if you’ve received a faulty product from us you can contact support@bluerobotics.com to sort out a replacement/refund as relevant :slight_smile:

New Pixhawk installed and solved light problems. Also noticed I’m getting a better power readout. Seems more of the fields are populated.

The Pixhawk had some different settings than my original which leads to a question of where the setup parameters are stored, pixhawk or QGC?

Thanks Eliot and Griselda,
Bill

1 Like

QGC stores setup information about the topside inputs (e.g. joystick button mappings, which UDP port video is streaming to, etc), and the autopilot board (Pixhawk) stores any parameters related to vehicle control (sensor calibrations, vehicle frame, servo port assignments, etc) :slight_smile:

If it’s relevant, you can save Pixhawk parameters to/load from file using QGC’s Parameters page, or reset them to the firmware defaults.