AP_Logger: stuck thread()

Hello, I am testing the Ardurover firmware on SITL from a Raspberry Pi 4 B with BlueOS 1.1.1 and QGroundControl v4.3.0. After installing Ardurover Firmware version 4.2.3 (STABLE) on SITL and loading the default parameters from the BlueOS web interface, I encounter the error: AP_Logger: stuck thread(), and the yellow message ‘Not Ready.’ Additionally, the vehicle configurations are not the same as those for the BlueBoat. I would like to know if there is a way to correct this or if it is due to some limitation in SITL for simulating the flight controller for the BlueBoat. Attached are some images of the configuration I made and the error that appears.

Are you still running into this issue?

I just encountered something similar with BlueOS and ArduSub SITL on a Raspberry Pi. I’m getting about 4 "Critical: AP_Logger: stuck thread ()" errors per minute.

My setup:

  • Pi 4B 8GB
  • ArduSub 4.5 BETA SITL
  • BlueOS 1.2 beta 8
  • GCS is QGC daily build, I also tried Cockpit and got the same result

There are a bunch of software layers between the AP file system and the actual SD card, this might be a challenge to track down.

This happens when the logging thread starves for IO. Either there’s something using a lot of disk IO in the system, or you could have a not-great sd card, see this issue.

I think that could also happen if you configure ardusub to generate a lot of logs, say with LOG_REPLAY=1.


I imaged a new 32GB SD card and I am still seeing this on 4.5 beta 1. The same cards work great on 4.1.2.

I have not seen this w/ the same software running on live ROVs, which is good. Just an annoyance.