Home        Store        Docs        Blog

No io thread heartbeat?


(Roar) #1

Hello
I have install the latest recent build of QGC,ArduSub V3.5-rc1 and Latest Ardusub-Raspbian Image.

The first time i started up Bluerov2 and QGC Everything worked,But the next time i startup its coming up: No io thread heartbeat

I have try two different card (Transcend premium 32gb/samsung premium 32gb) its coming up: No io thread heartbeat

I have also try the original from bluerobotics (kingston 8Gb) its coming up: No io thread heartbeat

If i go to the parameter and find the LOG_BACKEND_TYPE and set it to None (0) No io thread heartbeat disappears,but i can not Arm the Bluerov2,coming up preArm:logging failed

I use Window 10 and Win32DiskImager-0.9.5 to install the Ardusub-Raspbian Image to card.


(Jacob) #2

Hi @an-ron,

This message is coming from the Pixhawk indicating that it is having issues writing to the sd card in the Pixhawk. The Raspbian image and Raspberry Pi have nothing to do with this message. Have you been trying those SD cards in the Pixhawk, or the Raspberry Pi?

In the safety page, disable ‘Logging’ as an arming check in addition to setting the LOG_BACKEND_TYPE if you want to go this route.

Another note, there is a stable release (more recent than 3.5-rc1). This is available for download through QGroundControl. If you’re using Windows and your version doesn’t show it, you can install 3.5-rc2 through the beta selection, it is the same thing as stable 3.5 at the moment.

-Jacob


(Roar) #3

I have only been trying those SD cards in the Raspberry Pi with Ardusub-Raspbian Image on.

So that’s a card in the Pixhawk to.didn’t know that.

I have now formatted the card in the Pixhawk and No io thread heartbeat message disappeared.

thank you Jacob

But why did it happen? bad card


(Jacob) #4

We’ve had some spotty reliability issues in the past with our SD cards shipped in the Pixhawk. If you get the message again, yes it’s a bad card, and you may contact support@bluerobotics.com for a replacement.

-Jacob


(Roar) #5

Ok,I have many card that is better,So I can replace it.

How big can it be? (I have only 32- 64 gb, (I can buy a new card,Which has less GB)

Now there are coming up two new messages when bluerov2 is Arm:

Warning: EKF Bad
Warning: EKF2 IMU1 ground mag anomaly, yaw re-aligned

Have I forgotten to calibrate something?

I cannot see any 3.5-rc2 through the QGroundControl.
Do you have a download link to the 3.5-rc2 ?


(Jacob) #6

A 32GB card will work, I’m not sure if 64GB will work.

QGC just got updated last night with ArduSub 3.5 stable as an option. You can install the new QGC here.

This version also has an updated Safety page for ArduSub. Here, you can modify the EKF failsafe settings that produce this warning:

Warning: EKF Bad

This most likely means that the compass is getting a bad reading. This is to be expected if you are indoors, or near structures, as the compass is very sensitive and will be adversely affected by metal in the surrounding area.

This warning:

Warning: EKF2 IMU1 ground mag anomaly, yaw re-aligned

Is normal.


(Jacob) #7

Here is the stable V3.5 firmware if you still need it.


(Roar) #8

I testing the bluerov2 indoors,i have install the new QGC and stable V3.5 firmware everything works except pressure sensor.
when i use the Calibrate Pressure button,it coming up Calibration Command failed and on the Altitude-rel It says (m) -66.8

Could it be,any of the settings is wrong?


(Jacob) #9

Set GND_EXT_BUS parameter to 1, reboot, and let me know if that works. Also please let me know what GND_EXT_BUS is set to at the moment before you change it.

-Jacob


(Roar) #10

GND_EXT_BUS parameter was Disabled.

I can only choose between Disabled and Bus0.

I try Bus0,but is not working. Calibration Command failed and on the Altitude-rel It says (m) -65.3


(Jacob) #11

Click Advanced Options checkbox when you go to change the parameter, then you may manually enter 1.


(Roar) #12

GND_EXT_BUS is now Unknown:1

It`s working Altitude-rel It says (m) 0.0 after Calibrate and the temperature is also working.

instead of Altitude-rel should it have been depth ?

Thank you


(Jacob) #13

Altitude-rel is your depth, we’re continuing to improve support for ArduSub in QGroundControl. This little bit ‘Altitude-rel’ is hardcoded right now. Some day it will say ‘Depth’ for ArduSub.


(Roar) #14

ok,Thank you for all the help