Qgc connection issues

BlueROV2, pixhawk, win10.
I am getting video on QGC but no connection to controls or telemetry.
nav to gets me to the blueos frontend system page but there is no heartbeat top corner, however all the cpu % are moving around, so something is getting through.
Ping sonar app works and data is coming through that.
I have tried power down and up, cables disconnect reconnect, reboot PC etc multiple times over the last hour, still no connect to QGC. All firmware was updated a couple weeks ago and this all worked then. I put it away, didn’t even use the laptop in the meantime, took it out today and no connection.
I looked through the troubleshooting guide here (Troubleshooting · GitBook) but nothing seems to apply.
Does anyone actually use this gear for a tool, or is it just a time waster tinkering toy? I am seriously frustrated as I have a mission on monday to recover some scientific gear lost in the ocean last week that will pay a huge salvage award, but I need this thing to work when I need it, not just when it wants to.
Any help would be appreciated. thanks, Ron

and now, after sitting for an hour, I unplugged everything, battery, tether, USB, rebooted the PC, loaded QGC, plugging in USB, plugged in battery, and still nothing. Unplugged USB, re connected, and now it’s working across the board. WTF? Why so darn finickey? Will it work monday? No idea.
Still some suggestions from anyone who uses this on a regular basis would be helpful.

Hi @RV_Zephyr, sorry to hear you’ve been having connection consistency issues.

Given you seem to have had a consistent connection to the onboard computer (Raspberry Pi + BlueOS), but an inconsistent connection to the flight controller (Pixhawk + ArduSub), the potential causes are effectively

  • bad/faulty software on the Raspberry pi, that’s struggling to communicate with the flight controller
    • software bugs that are preventing proper communication
      • unlikely, since it’s sometimes working, but if you want you can turn on Pirate Mode and try out a recent beta (or development) image (you can always roll back if it’s not helpful)
    • a corrupted SD card
      • very unlikely, both because BlueOS is designed to avoid that, and because if corruption occurs it generally requires re-flashing the SD card to get any connection to work at all
  • damaged/faulty connection hardware (should show up with no autopilot connected on the Vehicle/General page of the BlueOS web interface):
    • Raspberry Pi USB port is unlikely - they don’t fail commonly
      • you could try a different port if you want
    • Pixhawk micro-USB port is possible if it’s been jiggled/strained excessively (they can be torn off)
      • if this occurs it’s quite probably that the accompanying PCB traces have also been torn off, in which case the flight controller will generally need to be replaced
      • there is an alternative port that can be worth trying if you’re short on time but have access to crimping tools or a spare cable with the right connector
    • USB to micro-USB cable is possible, and is probably the first thing I would check / try to replace
      • make sure to replace with one that supports data transfer, not a power-only cable

Was this the USB-B to USB-A cable at the topside, or the micro-USB to USB-A cable in the vehicle? If the topside connection was causing issues it should stop all communication, not just some of it. If that is the case then I’d recommend trying a different USB cable, and/or trying a different ethernet to USB converter in the FXTI box (or just using an ethernet cable from the Fathom-X in the FXTI to your computer, if your computer has an ethernet port).

There are several members of the marine robotics community who use our ROVs (and components more generally) for commercial and research work (many of which post on our forums, and are featured on our social media), including a variety of service providers around the globe. Having used lower quality vehicles previously I can assure you that our development, documentation, and support efforts aim to (and generally succeed at) making our products enabling and broadly usable by hobbyists and commercial users alike.

That said, our aim is enabling the future of ocean exploration, not to placate people into falsely positive opinions. You’re of course free to form your own opinions on our products and company, based on your lived experience, and we’ll do our best to provide products and services that meet and support the needs of our community, and try to rectify any mistakes we make along the way.

Hi Eliot, thanks for the reply. Right now we are anchored on the job site and I again cannot get a connection. on the vehicle/general page there is no autopilot connected. the only “board” available is the SITL simulator
Know that when I do get a connection, it works fine for hours, no interruption to the connection. I am trying again reboot etc to no avail.
phone is 503 632 5553

Ron - I am using BlueRov2 Heavys & Phantoms for daily work. It has taken some planning but my uptime is getting quite good. Eliot’s suggestions are the first step but it sounds like you may be having a similar issue to what I recently experienced.

When I upgraded to BlueOS it resulted in Mavlink overwhelming the compute on the PI. If left powered on on the deck (or second dive) it would overheat. The symptom was no heartbeat.

One of the two ROVs won’t generate a heartbeat at all. The other needs to be watched for heat.

BlueROV has published a beta version of BlueOS that may fix it. I have just decided to upgrade to the Navigator and bypass the issue with the PixHawk.

As you know I am up in Seattle. I see from your Facebook posts you are on a job in OR. Feel free to call if you want to walk through it out on station. We can also try to get an ROV down to you if you are in a real bind. - Ben - Coastal Sensing & Survey

Hey Ben, thanks for the reply. I did finally get a connection although I have no idea what sequence of things brought it about, which is the extremely frustrating part.
Previously I had upgraded firmware to the blueOS and latest in the pixhawk, so that is the configuration I was running that has the problems. To be fair, this connection problem has been with me since day one Mar 21.
The biggest problem by far is the lack of timely support available from BR. Waiting 2-3 days for an email to be returned, or an answer on this forum is unacceptable for any commercial user, not when you are talking about near $10k worth of product that is this complicated and singular in purpose.
Once I got comms with the unit I left it all plugged together and took the whole system out in the RIB, 16’ zodiac, and did the dive. I got a flood warning after some bottom time and found a puddle in the dome, looks like the camera is dead.
While it was on the bottom, I was using the ping 360 to look for the gear and although I was getting some returns, I couldn’t seem to get the unit close enough to look at with the camera. The camera video was being blown out by the yellow tether and the lights, and with the conditions on the bottom, I was getting only about a foot of visibility.
So overall, a total failure. We left the area and are back up north, I handed the job off to a friend at OSU who may be able to get it done. I can get the client your info if you would be willing to head down to Coos Bay, but the instrument package weighs around 1200lbs, so you need something that will handle that.
We are back up north in Port Angeles organizing for the next ops.
I follow you on FB as well, looks like we should know each other better for future collaborations. I talked to Mr. Fenn last night, I believe you know him too. We were discussing a step up to a phantom.
I would love to chat sometime, give me a call.
Ron on Zephyr

OK - sorry it didn’t pan out for you. Yes, I work closely with Crayton. I’m using Blueprint Subsea M750d imaging sonars for navigation and inspection. Also using their USBL’s. They are awesome - will completely change your world. For deeper work I am in the process of adding a Nortek DVL and hope to be running that on a job over the next 4 weeks. You should come down for a day and all three of us can go out. We are installing Blueprint equipment on Crayton’s Phantom’s also using the BlueOS Ethernet Switch and Fathom-X tether interface. There is a role for small and larger ROV’s.

That said doing a shakedown on your ROV is important. You can probably get to where you want to be. I am not convinced (once through shakedown) that the BlueROV’s have any more active intervention / maintenance than other ROVs under the 200k mark if you are using the R3 upgraded components.