Home        Store        Learn        Blog

BlueRov2 loses connection to QGC

Hey
We have bought a new BlueRov2, but it keeps losing connection to QGC after a few minutes. We have calibrated it, (a little difficult, because of the losing connection). We have looked at almost everything, and it seems to be in order, but it keeps losing connection to QGC.
We have tried to ping the IP and it never lost that connection, but loses the connection to QGC, what could be the problem here?

Do you have the latest software of companion (0.0.22), ardusub (4.0.2) and QGC (4.0.5)?

Yes, we tried with the newest firmware (we also tried 3.5.4) and software, we even downgraded the companion and tried an older QGC. When it loses connection, the lights starts to flash. WE also tried 2 different FathomX boards, both onboard and as topside. We also tried reflashing the Rasbian image.
We have also measured all the motors, and they seemed fine.

If you have an stady connection between topside and ROV I think the Pixhawk is the problem.

That was actually what we were discussing here.
So what you are saying, is that we need to try and replace the Pixhawk?

1 Like

We have replaced the Pixhawk and it seemed to be the problem, thank you.

1 Like