Home        Store        Learn        Blog

Lost Connection Issues

From the beginning with our BlueROV2 we have had sporadic “lost connection” in QCG, it works most of the time with random loss then reconnects a second later.

Just wondering if this was common or shouldn’t be happening at all and what possible areas to check to resolve?

It shouldn’t be happening at all.

What this means is that QGC has not decoded a HEARTBEAT message from the autopilot for at least 3 seconds (the autopilot sends the message at 1Hz).

So this is an issue with communication between the autopilot and QGC. Things to check would be:

  • Bandwidth test at 192.168.2.2:2770/network
  • Tether conductors are well seated/tight in interface boards
  • Interface board has adequate power supply
  • Try switching cables for new ones

Do you have any issues with the video when this happens?

If you can record a telemetry log file where this happens, then send me the log file that might help to narrow the issue.

Thanks. I’ll do some testing next week. I wonder perhaps if it is the power to the Fathom-X on surface as driving it off USB.

It does lose video as well.

Tether cables should be fine, been off an on a few times with similar results. It’s been this way since we first built it but been sporadic.

We are also having issues with our connection as well. Everything connects when the Pixhawk is directly plugged in via USB to the laptop, but when we try to connect through the tether, we get no signal. We are thinking it might be a firewall issue with our laptop, but are not completely sure. Any advice is appreciated.

Please try the troubleshooting steps here, and take notes of your results. If you continue to have problems, please share the notes of your results with me.

We have tried following this trouble shooting checklist and have had no luck. It is unclear if we are supposed to be using Raspbian or Companion, as one forum said Raspbian and the BlueROV2 software setup said Companion. When we tried using the links for companion, nothing showed up. I just want to make sure we have everything correct first. We had the latest Ardusub Raspbian image in our Raspberry Pi, and it pinged properly, but still had no connection. We have checked the IP address, the autoconnect settings, and rebooting the computer. Nothing has worked. Would it be possible to set up a conference call to figure this out? Thanks again.

@hh2500 Please contact support@bluerobotics.com to arrange an appointment, and please mention this conversation.