Home        Store        Learn        Blog

Work with ArduSub, problem with camera and lumen

Hello bluerow! I bought full complect for bluerow, There was installed pixhawk, raspberryPi3, Camera, preasure detector, 6 servos, I build it and check all electricity. After that became a problem. I tested servos. all fine, I started to test lumen, and somehow 5th and 6th servos started to work, but lumen wasn’t. And this servos worked like pulsed noise send to it. I unconnected them, and continue to work with tests, I tried to manipulate with camera servo, I used ardusub pymavlink script, it passed through, but nothing happened. After that I start to work with camera servo via qgc, it doesen’t work. But lumen nstarted. IS there some tips to understand which id belong to what device, and set commands to them to execute, I can’t understand all the logick. I red about messages, but still I try to find some messages and write my own, but based on such simple examples.

  • So first, can I get an explanation how to detect lumen, and after it up light, and down light.
  • Second, I think I have some problems with control via qgc, I installed it from :
    https://www.ardusub.com/resources/downloads.html#raspberry-pi-images
    my OS in Ubuntu 18.04 LTS , I think about that because I connected controller to it , and during my testing it showed that all buttons are worked correct, but device didn’t respond on everythink correct only, servos worked correct. But when I work with another devices, it behave like hell, send command to camera, camera did nothing, but lumen up.
  • Third, I have preinstalled ardusub v3.5.4, maybe, there is in it some problem.

I found the solving, I have to set outs to pixhawk from qgc, it solved the problem