Unable to test motors by picshawk-esc via mavlink

I’ve already read through the basic guides available from Blue Robotics. I’m quite familiar with the system. However, the system I want to set up is slightly different.

Before the bluerobotics products delivered, the current setup is as follows:

Two laptops with Ubuntu 20.04 Noetic installed, connected via SSH.

One of the laptops connected to a Pixhawk via USB (Mavros is installed on this companion laptop).

The Pixhawk connected to 8 ESCs (which are connected to motors).

On the main laptop: roscore is running.
On the main laptop via ssh : roslaunch mavros apm.launch fcu_url:=/dev/tty****:57600 is executed.

With this setup, the main and companion laptops are connected, and the main laptop is connected to QGroundControl.

However, when I try to manually test the motors via QGroundControl, they don’t work properly. Even though I’ve installed the firmware to the picshawk

So, the errors I’m considering are as follows:

  1. QGroundControl settings for them might not be correct.
    As far as I know, if calibration is done within QGroundControl, the ESC settings should be automatically adjusted.
  2. Wrong code I activated

Could you provide advice on this matter?

Hi @DANNY231, welcome to the forum :slight_smile:

Just to clarify, do the motors move at all when you try to run the motor test?

Note that the motor test assumes the vehicle is in the water while it’s running, and tries to flip any motors that are moving the vehicle in the opposite direction to the intended one, so the test will fail if the motors are plugged in in the incorrect order, or if they’re in an environment that doesn’t cause the autopilot to move when they spin (e.g. on a test bench / in the air).